0

I'm facing trouble installing a modded APK if the same app is already provided in stock ROM.

I'm using Micromax Canvas E481, not rooted yet. It has the JioSaavn app already installed. I uninstalled it to install a mod version of JioSaavn. But I'm getting the error "App not installed". However, the same APK is working on my other devices. The same is happening for playstore.apk.

JioSaavn is not a system app, it's just provided in ROM by Micromax. From application, it gives the option to uninstall it. I can install APK for any version of Saavn, it's just not letting me install the mod version. If I modify it using Lucky Patcher, it won't install it, but it will let me install the original APK for any version bypassing the pop-up from ES Explorer.

When I tried installing it from ADB:

C:\Users\Syed\Desktop\adb-tools_treiber\adb-tools>adb install C:\Users\Syed\Desktop\Saavn.apk
4451 KB/s (11231546 bytes in 2.463s)
        pkg: /data/local/tmp/Saavn.apk
Failure [INSTALL_FAILED_UPDATE_INCOMPATIBLE]
C:\Users\Syed\Desktop\adb-tools_treiber\adb-tools>
C:\Users\Syed\Desktop\adb-tools_treiber\adb-tools>adb install C:\Users\Syed\Desktop\playstore.apk
3648 KB/s (9862605 bytes in 2.639s)
        pkg: /data/local/tmp/playstore.apk
Failure [INSTALL_PARSE_FAILED_UNEXPECTED_EXCEPTION]
1
  • Now use the error as a search query. Example
    – Firelord
    Jan 18, 2016 at 13:14

1 Answer 1

0

INSTALL_FAILED_UPDATE_INCOMPATIBLE should tell you something. "app is already provided in stock Rom", "not rooted" and "I uninstalled it" don't match: w/o root, you cannot have uninstalled a system app (you probably have disabled it).

Same goes for Playstore: you cannot simply "update" it with a patched version. If it's an official version (signed by Google), you could update it – but then you must tell adb install you want to update: adb install -r xx.apk (note the -r, which stands for "re-install"). Not sure whether that works via adb for pre-installed apps, though (I've never tried).

13
  • Ok, for saavn i completely uninstalled it. To make sure it's not installed, I checked the package name and app name everywhere (even in root folder) but not found. Eventually I tried installing it using Es Explorer, and you know what.... The pop up says... Installed ver 4.3, new version 4.5. Where on earth is it installed in my mobile?
    – Akkitech
    Jan 18, 2016 at 14:09
  • So i first did it the natural way. Uninstalled it from my phone. It didn't work out. I then installed one from playstore and uninstall is from desktop using a software and it didn't work out. Then I uninstalled it using 'adb uninstall' and it didn't workout either..... So not sure what should I try now.....
    – Akkitech
    Jan 18, 2016 at 14:31
  • @Akkitech again, without root you cannot uninstall a system app (which is why "adb uninstall didn't work either"). As Firelord asked, please detail how you "uninstalled" it initially. I doubt you succeeded.
    – Izzy
    Jan 18, 2016 at 14:38
  • It's not a system app, its just provided in rom by Micromax. From application, it gives option to uninstall it. Let me rephrase.... I can install apk for any version of saavn... Its just not letting install the mod version. If i modify it using lucy patcher it won't install it but it will let me install the original apk for any version bypassing the pop up from es Explorer
    – Akkitech
    Jan 18, 2016 at 14:44
  • @Akkitech that sounds a bit contradicting: Everything "inside the ROM" is a system app. And sure you can install any official version (the app signature matches then, so this works even for system apps). But as soon as you patch them (e.g. using Lucky Patcher), the signature is broken (and usually a different one applied) and no longer matches, so the system will refuse accepting it as long as the original app is still there. As for Saavn I'm confused what that uninstall option inside the app is supposed to do.
    – Izzy
    Jan 18, 2016 at 14:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .