2

This question already has an answer here:

My bank's app has stopped working after an update. Trying to open the app gets the error "The device is rooted. For security reasons the application cannot be run from a rooted device". Then the app immediately closes.

I'm not really sure how there's security issues from being rooted. Especially compared to accessing the regular website from a desktop computer, which has no such kind of check. However, I don't really care. It's my device. So how can I get around this restriction (without unrooting my phone)?

marked as duplicate by Andy Yan, Matthew Read Aug 1 '17 at 22:16

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • A rooted Android guarantees that any rogue app (with root privilege) can peek into the data directory (contains critical info) of that banking app of yours. What Android version and device are you using? Have you tried RootCloak? – Firelord Jan 24 '16 at 15:33
  • @Firelord, mostly I'm banking on rarely using rooted applications and trusting those. Just like how I trust software I install on my computer not to spy on me (as if they did so, they could just as easily steal my banking information). This is with Android 5.1.1 on a Sony Xperia Z2. I have not tried RootCloak as I was unaware of it. – Kat Jan 24 '16 at 15:35
  • I have successfully used RootCloak. You need to install Xposed framework first. – Sourav Ghosh Jul 30 '17 at 17:47
3

UPDATE 2 - 6/21/2017: Most all of the below methods no longer work, especially on devices with Lollipop or higher Android. Currently the only effective method of hiding root access is using Magisk to root the device and use Magisk Manager to enable the Magisk Hide module and hide root from the app in question. Since this is an old question and I am just updating an answer, here is an article describing how to do it and below is a pretty rough guide to doing it.

Summary of steps:

  1. Remove old root method complete, this may mean you need to restore stock or reflash your ROM. Some ROMs have root built in, so check with your ROM maintainer/developer.
  2. Flash the Magisk installer ZIP using TWRP or other custom recovery
  3. Download and install Magisk Manager
  4. Swipe from left and go to Settings and enable Magisk Hide
  5. Press Back and select Magisk Hide
  6. Scroll through the Magisk Hide menu and select the applications you wish to hide root from

Your app should no longer detect that you have root.


Old answer - May still be applicable to devices with KitKat and previous Android versions

UPDATE - 9/2016: Most of the methods below will now fail since Google has updates SafetyNet API in how it detects root and modifications to a device. The SafetyNet API is a mandatory part of Google Play Services that auto updates itself regardless of your settings, and many apps are now using this to detect root or modified systems. In fact, in Android 7.x devices, an otherwise stock device with merely an unlocked bootloader can fail the SafetyNet check. More information on SafetyNet API can be found here.

RootCloak will work with most applications to hide root, it is an Xposed module, or RootCloak Plus which is a stand-alone app.

The reason banking and other financial apps don't work on a rooted device is for the potential of private information being obtained by other apps or users with root permissions. Like it or not, there is no denying that having a rooted devices can potentially have security and privacy concerns, even if only in theory. Suhide by Chainfire is another great solution.

  • And BTW, this is your financial institution being paranoid... many don't have this restriction including Wells Fargo, CitiBank, Capital One, US Bank, and most credit unions (most use a common service for this). – acejavelin Jan 24 '16 at 15:43
  • Sadly, RootCloak Plus doesn't seem to work on this app (and RootCloak's dependency doesn't want to install on my phone). – Kat Jan 24 '16 at 16:01
  • I'm especially confused because I was under the impression that my phone wasn't rooted anymore. My backup program stopped working and SuperSU doesn't detect root. In fact, no other app considers the device rooted. I gave up on that ages ago. – Kat Jan 24 '16 at 16:03
  • 1
    @Mike sound like you need to flash factory firmware image, your device is in an unknown state – acejavelin Jan 24 '16 at 16:19
  • 1
    An alternative would be using Magisk (with the Magisk Hide feature) – samdd Jun 14 '17 at 15:06

Not the answer you're looking for? Browse other questions tagged or ask your own question.