I have a Samsung I9305 running rooted stock Android 4.4.4 with Xposed framework.

I used to be able to use USB OTG Storage devices flawlessly.

However, recently, none of them mount. I've tried third party root drivers such as Paragon, but it didn't help. I've tried drives formated in FAT32, exFAT, ext4, NTFS and HFS+ (for the latter I tried using the Paragon driver.) None of them work now.

OTG mice and keyboards still work, so that leads me to think that this may be a software problem.

Is there anything, short of a full firmware restore, that I can try to make this work?


Try the app USB Device Info it might assist with debugging USB issues.

This application will provide information about almost all currently plugged-in USB device (see below for more info about the 'almost').

Information includes: •The Device class •The USB device path •The Vendor ID (VID) and the Product ID (PID). •A List of all interfaces and their endpoints.

If you download the accompanying databases, the application will also be able to provide you with additional info such as the Vendor of the device (which is not necessarily the brand!), the vendor's logo and the product name.

This application uses two different methods to collect information:

  1. Android mode will use the native android USB API.
  2. Linux mode will parse /sys/bus/usb/devices/.
  • Hi, welcome to Stack Exchange. Thanks for your answer. Unfortunately, I no longer have access to the device that had the problem, so I'm unable to try your suggestion.
    – Fiksdal
    Sep 4 '16 at 10:11
  • Please link the app from Play Store and explain why you think it would help (from the app description)
    – beeshyams
    Sep 4 '16 at 10:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.