Motorola Xoom running Honeycomb 3.1, for the last few days, every few minutes I get a popup in the middle of the screen saying:

Sorry! The process com.google.process.gaps has stopped unexpectedly. PLease try again. Force close

This happens when I'm running pretty much any app: browser, Google Reader, Gallery, GMail, File Manager HD, etc. Can't work out any pattern to i, sometimes it happens every couple of minutes, sometimes I can go for 10 or more minutes without seeing it.

What's causing this (or how can I tell what's causing this) and how can I stop it?

Update This does appear to only happen when I've got a network connection (mine's a Wifi only tablet) - after installing alogcat, I did a 40 minute commute on a train using Google Listen and playing Angry Birds, with no errors popping up at all (and therefore no way to catch anything in the log. Will have to wait until I'm home again to investigate further.

  • Any clues in the logcat?
    – Chahk
    Sep 16, 2011 at 2:27

1 Answer 1


After a lot of experimentation and backwards and forwards and disabling and enabling various things, I've got it to the point where I haven't seen that error popup for about a week now (which is a huge improvement over it appearing every 10 minutes).

Unfortunately Logcat never seemed to show any obvious, enlightening errors when the Force Close messages popped up, so there was nothing to work on there.

Various posts on web forums suggested that going into Accounts and Sync disabling sync on Calendars and Contacts, then clearing the data on the Calendar and Contacts app should help, but it didn't seem to for me.

In the end what I think solved the problem was:

  1. Completely deleting all my non-primary Google Accounts off the device (I have a primary Google account, which is a Google Apps one, plus another Google Apps account and a normal GMail account)
  2. Disabling all of the sync on my primary account
  3. Clearing the data on the calendar and contacts apps
  4. Leaving it an hour before re-enabling the sync on my primary account
  5. Leaving it a day before adding back my secondary accounts, and enabling their sync

Not 100% sure which of those steps solved it, but after doing all of those steps in that order my problem has gone away.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .