3

On boot my mobile phone goes to the lockscreen background but doesn't show the unlock symbol.

I've tried dragging the button blind but it's not just that it's not visible, it's not there. Neither does the "emergency dial" button show. The rest of the UI shows; the time, alert bar with wifi symbols and such. I've also tried using the Google Android device manager (ADM) code reset, the numbers don't show to allow input of the code; Safe Mode doesn't show the numbers either.

The phone is an Acer Liquid E3 (E380) running Android 4.4.2 (Kitkat?) and somehow I've managed to remove the lockscreen - I think perhaps it was with [correction:] System App Remover when trying to remove wallpapers after rooting with Kingo Root; but I had just changed to allow voice unlock so it may have been that.

How can I unlock if the buttons don't show? I know the passcode and the voice unlock commands.

The phone is online, Wifi is activated. When entering Safe Mode it showed it was downloading something, for example.

Developer mode is active but I think that USB debug is off (adb devices shows the device but says "offline" next to it).

I can access the recovery menu (power + volume-up at boot) - is it possible to "adb sideload" something that will help (like a replacement lockscreen?). Like I said it's not the code I have problems with, just the UI not showing.

I've seen use of adb shell input text 1234 to enter codes, but presumably this needs USB debug to be enabled; can I force send text that way? If I plug in a USB keyboard is there a button press that operates the "unlock" onscreen button?

Occasionally when I bring up the power off menu the number keys will show underneath (suggesting the software to show them is installed still) but touching the screen dismisses them with the menu leaving me on the broken lockscreen.

Any suggestions other than a factory reset? Thanks.

Edit: sometimes the voice unlock screen is shown behind the "power off" dialog, again it is dismissed as soon as one closes the dialog.

Edit2: I did a full data wipe [ie factory reset], ensured PIN access was set, used a different theme, etc., am now in same position but have managed to enable USB debug. However, using adb shell to provide input doesn't unlock, it will turn screen on but entry of unlock code appears to fail.

Edit3: tried again with ADM, it puts up a black lockscreen with a padlock symbol that looks like a drag-button but I can't interact with it. Also since wiping I put a widget (messaging) on the lockscreen which I can interact with.

  • 1
    Do you notice a change in screen resolution? – NVZ Jan 26 '16 at 21:29
  • No, screen seems normal. – pbhj Jan 26 '16 at 22:53
  • Do you have a custom recovery installed? – Aaron Gillion Jan 27 '16 at 5:05
  • @AaronGillion - no, it's stock recovery, I tried to load one (CWM) through fastboot but it wouldn't let me write the recovery partition. – pbhj Jan 27 '16 at 12:07
1

Now that you have USB debugging enabled, you can try resetting some of the database flags associated with the lockscreen...

You will have to adb push sqlite3 to your device, the only independent binary that worked for my devices I pulled from here: XDA - sqlite3 binary June 2015

adb shell
cd /data/data/com.android.providers.setting­s/databases
sqlite3 settings.db
update system set value=0 where name='lock_pattern_autolock';
update system set value=0 where name='lockscreen.lockedoutpermanentl­y';
.quit

If you happened to accidentally delete Keyguard.apk and the above does not work, you will have to get another Acer Liquid E3 off ebay or the like (about $80, all we need is the apk, then resell) and adb pull from the source phone and adb push to the destination phone.

I would recommend just flashing stock firmware, or pulling the apk's from stock firmware, but unfortunately that does not exist.

  • Acer list a file on their website as being the OS for the phone, wondering if this is flashable? Also I have the .apk files that I removed backed up - how would I know what files to pull-push? – pbhj Jan 27 '16 at 12:03
  • 1
    Well geez, you backed up the apks? Adb push them all back! A factory reset cannot account for those deleted apks. – Aaron Gillion Jan 27 '16 at 13:29
  • So I just do adb push recovered.apk and it will put them in place, or do I need to do something more nuanced? FWIW I've reinstalled twice now and am no closer to getting a lock screen that works. – pbhj Jan 27 '16 at 16:42
  • 1
    Actually, there is a little more to it, if those apk's were under /system. Here are the system app commands answered here on Android Enthusiasts. If those commands fail then just adb install them as user apps (easier) – Aaron Gillion Jan 27 '16 at 21:55
0

So I downloaded the OS zip given on the Acer website and trawled the /system/app and /system/priv-app files looking for image files that matched the lockscreen. They turned up in /system/priv-app/AcerLiquid.apk.

From there I did adb install ./AcerLiquid.apk (initially I tried with adb shell pm install ... but that failed with a permission error). On rebooting the phone I was then able to see AcerLiquid listed in the system apps; then enabling the lockscreen worked and the phone is returned to full working order.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.