My problem is that my rooted android phone with Terminal Emulator app doesn't seem to be executing the 'su' command correctly. I am trying to execute this command, after having executed the 'su' command:

busybox ifconfig eth0 hw ether 00:0a:95:9d:68:16

which returns this:

ifconfig: SIOCSIFHWADDR: Operation not permitted

I think this issue is caused by not having root rights, although I did execute 'su'. I noticed the '$' didn't change to a '#', that indicates you have root rights.

My Motorola Moto G first gen. is running Cyanogenmod with android 6.0.1

I enabled root for apps under developers options.

This is the guide I'm using: Spoofing MAC address. Some people encountered the same issue, but no solution was found.

Anyone know how to get root working on Terminal Emulator app? Any help is appreciated!


  • What does su -c 'id' return? Which CM build are you using?
    – Firelord
    Jan 28, 2016 at 12:37
  • It returns nothing at all. Also I'm running an old nightly 13.0-20151215-NIGHTLY-falcon. I don't want to update because I have to factory reset my phone for some reason.
    – Pizzapim
    Jan 31, 2016 at 19:46

2 Answers 2


It didn't work for me using Gboard (Google's Keyboard), so I tried Samsung's Keyboard (use the system's default keyboard) and it worked.


My device is a rooted Motorola Razr HD smartphone (also known as XT925) currently running Android 4.4.2 (stock ROM) with the Terminal Emulator app installed. In my case, all I have to do is to start Terminal Emulator and then execute this command:

su -

This causes me to become root and thus be able to execute any other command I want.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .