1

I am trying to upgrade the firmware of samsung galaxy S LCD using Samsung Kies. I am using the recent version of Kies. But during when I click start update it is showing that the FirmwareUpdate has stopped working. and it is showing preparing firmware upgrade components forever. Please advice me what to do.

  • Have you attempted the update multiple times? – Matthew Read Sep 16 '11 at 15:11
  • We've had multiple questions about updates with Samsung Kies. Have you already checked the questions tagged with samsung-kies? – ale Sep 16 '11 at 15:12
  • actually I have read some. But some of them are suggesting update through Odin rather than Kies. I read in forums that some of this Odin updates are creating issues with camera and audio. That's why I tried to update through Kies. I am using the latest version of Kies and upon connecting the phone it pops up a firmware update message. So I have tried many times and it is always showing the same error. Now I think it may be a problem with Windows 7? can I update it in Linux ? – Happy Coder Sep 17 '11 at 10:39
1

I'm having the exact same problem and just received the following message from Samsung:

The Kies software does not detect the handsets, there are several causes for this and a process of checks will discover the cause and show the solution:

  1. Check the system specification is correct for the KIES software.
  2. Check the correct and up to date version of the software is being used.
  3. Check that handset is set on the correct mode which is SAMSUNG Kies.
  4. Be sure that the handset show connected ‘not connecting’ on home screen.
  5. Try to test a different USB port and restart PC.
  6. Check in device manager that the driver has been installed and update if required
  7. If handset has device manager (download one from market place for android 2.1 or higher)
    ensure that all tasks have been ended and handset is in the idle mode before connecting ‘download the task killer, it is an application used to close all the applications (not just minimizing them)’
  8. Completely remove current version of the Kies software and re-install
    the latest version from the website.
  9. Test with different PC.

It's quite a number of possibilities being mentioned.

1

Had same problem.

Open the App Drawer, tap on Settings > Storage, tap on Unmount SD card

Then you have to physically remove the SD card. Worked now!

  • yeah okay..Actually I have asked it in 2011. Anyway now also I am using the same phone and running on custom firmware now :) – Happy Coder Jan 23 '13 at 8:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.