6

I'm rocking a Samsung Galaxy S6, 5.1.1, build number LMY47X.*

When turning on the "Do not keep activities" developer option, the toggle turns green. It is toggled back off as soon as I navigate away from the developer options screen, and my testing shows that it is indeed off.

A workaround was to toggle it on, then lock the phone. After unlocking it, the toggle stays on and activities are not kept. The opposite problem is then present: it won't turn off. The workaround above does not seem to work in this case (I wonder if it was a fluke).

Some googling brings up a few instances of people with S6's and Note 5's with a similar problem, and a few conspiracy theories around samsung intentionally leaving it locked on, but nothing concrete about how to solve this.

Is this a bug, a dirty Samsung battery-saver hack job, or am I alone in experiencing this?

  • Is it a rooted phone? – NVZ Jan 28 '16 at 8:58
  • No, it is a stock phone. – Tom Jan 28 '16 at 19:16
10

Mystery solved!

Clicking the toggle does nothing. Clicking the text itself works, though. It looks like Samsung's devs have a click listener on the list item, but not the toggle switch itself.

0

I have a galaxy prime core phone that I upgraded to s8 and tried the smart switch. Kept getting that same message with the same results. What I did was toggle the button off for ALL developer options at the very top of the screen. It worked. Transferring media as I am writing this. One note though, this is an extremely slow process, might want to try just transferring via a computer

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.