3

The issue (summarized)

My phone will not be recognized by ANY computer, regardless of OS, with or without drivers. Kies is not installed, nor Android Transfer (in the case of my iMac), and I am at my wits end. What can I do, if anything?

TL;DR

I have a bit of a problem I am completely lost with...

Bit of a backstory. Three months ago I was given a Refurbished Samsung Galaxy Avant with a one month warranty. It worked perfectly; computers recognized it and allowed me transfer files, Odin saw it (though I didn't do anything with it. I still had the warranty to wait out first), everything. Now skip forward two months.

My warranty is finally over. I got excited (all the bloatware on the thing was beginning to drive me nuts) and plugged in my phone to load it on Odin. But then Windows gave me an error: Your device is not recognized or has malfunctioned. (yadadada. Don't want to write the whole thing.). Confused, I did what every good techie does: I googled my problem. The results all said the same thing: try a new port, try a different cord, do you have drivers installed? etc.

I tried everything. I restarted my phone, restarted my phone in the stock recovery and cleared the cache, tried changing dialer settings to adm or mtp or both, I restarted my computer, I tried all my USB ports, I tried all my usb cords, tested my usb cord and ports by plugging in another phone (which it recognized properly without any difficulty.), I uninstalled and reinstalled drivers. I even went as far was factory resetting my phone and reinstalling Windows 10 (which was annoying, but I needed to anyways), to not avail. Getting desperate, I tried booting into my Ubuntu installation. Ubuntu didn't recognize it. I tried my other PC I have (running Windows 7), got the Malfunctioned error again. I even tried my late 2013 iMac (which is a completely different post I could rant about). Nothing is recognizing my phone, and I am at my wits end with what to do, if anything.

I tried taking it back to where it was purchased from, but they told me they can't do anything about it. It was two months past warranty and it charges just fine. Computers just won't recognize it or the internal SD card.

What I have tried:

  • different USB cord / cables (including the cable I used a few nights before for flashing another device)
  • different USB port
  • tested both ports and cords by plugging in a different Samsung device, which it recognized and opened properly (so I'm 99% sure it isn't drivers)
  • went to dialer settings (*#0808#) and changed to mtp+adm.
  • went to stock recovery and cleared cache
  • factory reset phone
  • reinstalled Windows 10 (really wasn't that desperate. Needed to reinstall anyways)
  • uninstalled and reinstalled drivers
  • tried different computers
  • tried different OSes (including Windows 10, Windows 7, Ubuntu 14.04, and El Capitan) of which none will open or recognize my phone
  • removing and putting back sim card (weird trick some claim it works)
  • turning on/off developer mode/debugging in settings
  • Even one or two highly recommended rooting apps were tried.
  • I have literally almost tried everything.

Any help whatsoever will be helpful and sorry for all the information! I just wanted to make sure I didn't miss anything... Thank you! <3

if you ask why I am so desperate for root on an otherwise perfectly working phone: I dislike KitKat (give me lollipop, marshmallow, or even jellybean any day of the week), and all these built in bloatware is driving me crazy and I want to get rid of them

0

Okay, so really late reply, but I thought I might as well update. Apparently my phone has a faulty USB port and I don't have any way to fix it. Using Kingoroot, I managed to root my phone then promptly changed it to SuperSU. I then used System App Remover (Root) to get rid of those bloatware apps I hated so much. Finally, using Flashify, I flashed TWRP.

Searching XDA I did find a ROM for it, but it is a bit outdated. However, it still works, and it is what I am using right now until I can get around developing my own, when and if that may be.

Thank you guys for your support and ideas anyways!! <3

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.