0

I am new to Android and I am not the owner of the current device (LG Nexus 5) I use. I come across this problem: I am not the owner of the device. Instead, I am the second user. When I want to call someone, it prompts an alert box saying that

only emergency calls are allowed by the owner.

Similarly, when I open the Messenger app, another alert box prompted:

this app isn't allowed by the device owner

so I set Hangouts as the default SMS app, but SMS is disabled and not be able to enable.

Other features work fine. The reception is full. Cellular data works. I can even accept calls, just not be able to calling out or sending SMS. Do I have to contact the owner, for them to unlock the calling and texting features?

4 Answers 4

2

when your phone is under guest it wont allow you to have access to everything. switch to original owner and your phone will work again!

1
  • You may be right but adding a reliable Source to support would enhance value of answer, else it is a comment and would attract downvotes
    – beeshyams
    Nov 3, 2016 at 8:49
2

Ok, log back in as the owner of the device (if you can)

Slide down the menu from the top

Click on the user icon

Click on "More Settings" down the bottom

Click on the settings cog next to the user you want to enable phone and sms for

Click "Turn on phone calls & SMS"

This is working for Android 7, Google nexus 5x

Found in this guide: http://www.ibtimes.co.uk/android-5-0-lollipop-how-enable-remove-restrict-guest-user-mode-1470690

0

Contacting the owner is the simplest way to do that -- they'll probably need to have the phone physically in hand, too.

2
  • Which setting do they have to modify to enable the features? Jan 29, 2016 at 16:06
  • No idea; I don't have a Nexus (any version), nor ever tried to change those settings on my Galaxy S4.
    – Zeiss Ikon
    Jan 29, 2016 at 16:19
0

Here are 2 approaches

http://www.thecellguide.com/ has detailed pictures to go along with the information below, which has been directly quoted.

  • Go into Settings > Storage and tap on Cached Data and select ok to clear data.

  • Go into Settings > More > Cellular Networks > Preferred network type.

  • Select "2G" as your preferred network mode. - Turn your Nexus off completely, wait 10 seconds and then turn it back on again.

  • Go back into Preferred Network type as shown above and switch it to 3G.

  • Then select Network Operators > Search Networks - Select your Carrier and you should connect successfully.


https://productforums.google.com/forum/m/#!topic/nexus/tkdAkJEAXmo information below is from Srijith G Nath answer.

A lot of people have been having trouble with their network connections on the Nexus 5. Sometimes it will struggle to connect properly when switching between Wi-Fi and a mobile network; sometimes it seems to run into issues when switching between 3G and 4G. Sometimes it is dropping onto EDGE or GPRS when 3G or 4G is available. For some people it happens when the Nexus 5 sleeps and there are suggestions it might be related to fast dormancy if it’s not supported by your carrier.

Workaround:

Hold down the power button and reboot your Nexus 5 and the connection should return.Try going to Settings > Wireless & networks > More > Mobile networks >Network mode and choosing it manually.

Potential fixes:

  • There’s an outside chance that your APN settings are wrong. Check with your carrier to find out what they should be and go to Settings > Wireless & networks > More > Mobile networks > Access Point Names to make sure they are set correctly.

  • Try using your SIM in another phone to make sure it’s not an issue with the SIM card.A few people say the problem is gone after a factory reset or replacement handset, but there are also reports that neither helps, so it’s definitely not a guaranteed fix.

5
  • I do not see Cellular Networks under Settings -> More, and switching to 2G or 3G will probably slow down my cellular data speed, since I am using 4G LTE and the connections are fine. Jan 29, 2016 at 19:49
  • In terms of Cached Data, I have 1.57GB after I cleared them, I am not sure if that is normal. But it does not work. Jan 29, 2016 at 19:50
  • Switching to 2g forces the phone to locking to base signal.
    – HasH_BrowN
    Jan 29, 2016 at 20:36
  • The only other option I can see is try the SIM card in another device and see if it connects to make a phone call.
    – HasH_BrowN
    Jan 29, 2016 at 20:38
  • unfortunately on my phone I cannot select preferred networks. SIM works, I tried it on another phone. Feb 2, 2016 at 17:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .