I am trying to push a media file to a rooted Samsung S3 running Samsung's stock Android 4.3. I have tried

$ adb push file /storage/extSdCard
failed to copy file to '/storage/extSdCard/file`: Permission denied

I think it's due to

drwxrwxr-x system   media_rw          2016-01-29 21:03 extSdCard

and the shell user not being in media_rw. I tried to chmod 777 /storage/extSdCard but the permissions don't change.

Having read various answers and other content (such as work-arounds) on the web without success, I'm left wondering if it's possible on the S3 to use adb to write to the SD Card ?

This answer would imply that it isn't possible, but hopefully that isn't the case?

  • 2
    Elevate to a root shell with SU command to get the #.
    – Bo Lawson
    Jan 29 '16 at 21:23
  • 1
    Yes that works in adb shell but I don't think you can do su' with adb push as far as I know...
    – starfry
    Jan 30 '16 at 14:42
  • Try running "adb root" to enable adbd to run as root before pushing and see if that helps
    – AguThadeus
    Feb 1 '16 at 12:30
  • Do you've a Nandroid backup? You can mess up with few things here, to see what works out. For example, change the group from media_rw to sdcard_rw recursively and see how it works out. SELinux may also be involved here so you may also have to take care of it.
    – Firelord
    Feb 1 '16 at 13:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.