My Android device (GT-S5570 running 2.2.1) is having connection problems with my home Wi-Fi network (ZyXEL adsl P-660HW-D1). The device connects ok, gets an IP address, and sees all other computers on the network (using Overlook Fing). I have good signal strength, and there are no conflicting Wi-Fi networks around.

However, ping results are rather mixed. Depending on the attempt results come back with packet loss of anything from 100% to 0%, usually one or the other, but something around 20% or 60% happens quite often too. This happens with all the devices on network, including the gateway. Other devices can ping each other just fine, independent of connection type (Wi-Fi or Ethernet wire).

There are also some other wlan problems with one (but only one!) of the computers: 1) It has some random touble connecting to the wlan (authentication failure), but when it gets a connection it stays connected without connection issues. 2) Sometimes ping results show some random packets with weirdly long latency, and occasional lost packet (<2% if even that). This would point to trouble with the Wi-Fi settings. However, the packet loss doesn't appear parallel: The Android can get packet loss while the computer at the same time reports perfect ping.

The Android device always gets a connection, and stays connected to the Wi-Fi even when it's getting 100% packet loss. The Android device also works perfect in any other Wi-Fi I've tried. Also, any visiting computer I've tried connecting to my home Wi-Fi has had no trouble.

The router has the original (which is also the latest) firmware, and I haven't meddled with the settings it came with - I woudn't know which settings to meddle with.

How do I debug this further? What Wi-Fi settings could be causing this?

(This also seems oddly similar to the trouble described in this question.)

(Cross-posted to Super User since while the main problem is with the Android device, the problem itself appears wider.)

  • It does seem similar, so: Has this always occurred? Did the device come with the version of 2.2.1 you have? Sep 17, 2011 at 15:39
  • @Matthew Yes, I just got the device last week and it came with the 2.2.1. (No updates to 2.3 available, officially.) Also, the other problems (with the laptop) have always been there as well. Sep 17, 2011 at 16:42

2 Answers 2


My Android tablet also stopped connecting to my home wireless and reports connection out of range even when sitting in the same room as my access point (AP). I've looked everywhere for a solution doing everything from restarting my AP and tablet, changing the PW and even security mode (WEP, WPK, etc) with no success. My AP is an old router set to AP mode and uses a single broadcast channel. I went in and reset the channle from 13 to 11 and VOILA! Instant connection with my tablet.


Use the combination of these 2 tools, it could be that the neighbouring Wirelles is interfering if that is the case you can chage the channels.

2 nice tools to use:

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .