0

The following things happened, leading to the "bricking" of my phone, lenovo s860 with android ver 4.4.2:

1) I got a virus, associated with an app from the play store.

2) The virus was inside the FirewallService, thus unable to be blocked or uninstalled

3) The only decisions I found online included rooting of the phone, because even after complete data wipe/format this virus still survived http://forums.androidcentral.com/ask-question/621569-firewall-service-keeps-showing.html

4) So I tried with the following rooting method, which did not work https://www.youtube.com/watch?v=AnZE7knrNVw

5) I followed all steps carefully but when I finally restarted the phone and downloaded the Root Verification app it said that the root has failed

6) Tried with other apps, all said that the phone was not successfully rooted

7) The virus was still messing with my phone, it even started installing apps

8) Then I did the amazingly stupid thing to go into recovery and wipe System, without making backups

9) When I tried to restart, a message followed "Are you sure, there is no OS installed"

10) Connected to PC, re-installed recovery using the same video, but now recovery shows a flashing picture instead of going to the menu

Please help me, I really need the phone for work and I can't afford waiting a month or two for Lenovo service

0

I managed to repair it.

1) I installed the following android verion http://www.needrom.com/download/lenovo-s860/, but it upgrades to a chinese Vibe 2.0, which is very customised and has no Google Play Store, as weall as all other Google apps.

2) So I used the "Upgrade Firmware" option on the PC program (SP Flash Tool) instead of the "Download" one to install http://www.needrom.com/download/rom-stock-4-4/ (this site contains very precise instructions, check it out before doing any of the steps)

3) Now phone works perfectly, but it has IMEI connection problems - IMEI Invalid - Lenovo S860, rooted android 4.4.2, nothing works

4) KingoROOT seems to fix the IMEI problem

5) Phone up and running perfectly

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.