I'm really hoping somebody can help me out here because this is frustrating me. First off, I have a Samsung Infuse 4G with AT&T. I was able to lock onto satellites indoors pretty quickly before. So I rooted my phone with SuperOneClick last night, and everything was good. No problems. However, I was having trouble replacing my recovery file with a modified recovery file. So after some research, I came across Odin on XDA Developers(http://forum.xda-developers.com/showthread.php?t=1092021&page=8), that was supposed to do exactly what I wanted: Flash me to a stock ROM with root and modified recovery. It was a successful flash, except for one little problem. Any application that used the GPS hardware would fail to initialize. So "luckily" for me, the thread I flashed to root+modified recovery also had a 100% stock ROM to flash my hardware with, so I did that. However, I had the same issue still of not being able to run GPS dependent programs. So I did a manufacturer's reset, and now every application will initialize and run, however I can't LOCK into satellites now! I've tried using GPS status to clear and download AGPS data with no luck. I've tried several different supl servers, including google and nokia, no luck.

I know this is my fault, but can somebody help me out of this mess? The only sort of location that works on my phone is mobile/wifi location.

Thanks in advance for any help I get.

Edit: It appears that even though I flashed a 100% stock rom to my device, there are GPS locking issues with the rom. Damn..

  • Go to the dialer and dial *#*#1472365#*#*. Does it bring you to a menu called LbsTestMode? If so, I might be able to help. Sep 18, 2011 at 16:53
  • No, but *#*#3214789650#*#* brings me to LbsTestMode
    – Apple
    Sep 18, 2011 at 16:57
  • OK, I'll post an answer. Sep 18, 2011 at 16:57
  • I fixed it!!! I appreciate ANY time you spent researching this for me. I will tell you exactly how I fixed it, so this can help other people with the same problem. I flashed back to the stock+root+modified recovery rom, and then I did a manufacturer's reset of my phone and now everything works flawlessly!
    – Apple
    Sep 18, 2011 at 17:19
  • 1
    Great, glad to hear @Apple. I would have suggested something along those lines as well if I were more familiar with your device. You should post that as the answer. Sep 18, 2011 at 17:21

1 Answer 1


It sounds to me like the flashing wiped out all the info your phone had about local satellites -- the good stuff it retrieves itself, not the aGPS crap :P. If that's the case then hopefully this will help; this a process I've used on my Samsung Vibrant.

  1. Ensure GPS is disabled
  2. Go to LbsTestMode
  3. Hit Delete GPS Data
  4. Go into Application Settings
  5. Change Start Mode to Cold start
  6. Back out to the home screen, then reboot your phone
  7. Enable GPS
  8. Go to LbsTestMode
  9. Hit Get Position Test. Let this run to completion (normally a good 15 minutes or so) — the lat/long info will get filled in and you'll see [*] next to several of the satellites it finds, the more the better. This will work best if you go outside and walk around.
  10. Back out and go into Application Settings again.
  11. Change Start Mode back to Hot start.
  12. Reboot and, hopefully, enjoy your functional GPS.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .