14

I've been used to downloading PDFs on my phone and have them directly saved on my downloads folder. But just recently, whenever I download PDFs, Google Drive viewer shows up. I know there's a download option on Google Drive viewer. But when I open the file, it prompts that there's no app that can read it. I have Acrobat and Drive that I used to read PDFs with.

I think I changed the defaults by accident (I did not assign one before). How do I change that, if ever?

My phone's a Samsung S5. I'm using Chrome for it.

Edit: Sorry for posting this on the Web apps, didn't know there was an Android Enthusiasts. Anyway, I think from some of the research I did the update for Google Drive makes it the default for opening PDFs. I checked the defaults, it did not have one. I just uninstalled the update for Google Drive as a temporary solution. Thanks for the help!

migrated from webapps.stackexchange.com Feb 5 '16 at 18:17

This question came from our site for power users of web applications.

  • Which OS version is it currently running? – Chahk Feb 5 '16 at 20:19
  • 1
    Possible duplicate of How do I change the default Complete Action With? – Firelord Feb 6 '16 at 13:31
  • 1
    Note there is an app called google pdf viewer and a a function within drive called drive pdf viewer, wich are different. The first one can be unistalled in application manager. – Santropedro Jan 12 '17 at 23:50

17 Answers 17

7

Try clearing the defaults for the Google PDF Viewer app. You can do this on Android 4.x - 5.x by doing the following:

  1. Go to Settings -> Apps -> All.
  2. Scroll down to Google PDF Viewer app and tap on it.
  3. Scroll down to the Launch by default section and tap the "Clear Defaults" button.

Next time you try to open a PDF, a pop-up should present you with options of all the installed apps that handle PDF viewing.

  • 4
    For me, there's no separate PDF viewer app, and clearing defaults for the Drive doesn't help. – wizzard0 May 3 '16 at 10:04
  • Disabling the Drive app makes it "cant open file" even that i have adobe pdf and fbreader installed – wizzard0 May 3 '16 at 10:22
7

I had the same problem using Firefox on Android - totally maddening - but fixed it.

After installing Google Drive all my links to pdfs would open with Google Drive PDF Viewer.

I fixed it by, in Firefox, going to about:config in the location bar, then finding "browser.download.preferred.application/pdf" and doing a Reset there.

The next time I clicked on a link to a pdf I got the choice to Download, or use Google Drive PDF Viewer.

Shouldn't it be there in Chrome, under the hood somewhere ?

Btw, that "browser.download.preferred.application/pdf" in Firefox only seems to show up after a choice has been made, in this case, forced by the install of Google Drive. Seems redolent of the old browsers wars.

1

I just had this problem on Android 7.0 Nougat. I on a pdf/drop box link I accidentally clicked set Drive PDF Viewer as default.

Similar to others.. To fix this in Nougat.

You must go to Settings->Apps->All->Drive-Open by default (little bit tricky)

"Clear Defaults" might be disabled, however the first entry "Open supported links". Will be set to some value, set it to something other than "Open in this app". I set it as "Ask every time".

Hope this helps.

1

I went to Settings > Apps and Notifications > See all apps > Drive > Open by default > Clear default. This worked for me. Now I'm once again prompted on which app I want to use in opening PDFs.

I'm using a Google Pixel 2

0

I believe you will have to clear the defaults for Google Drive. Have you installed the PDF viewer from the play store? If you have you should clear its defaults for sure.

  1. Go to settings
  2. Then Default Applications
  3. Then click on the Google Drive app and the Google Drive PDF Viewer app clear button to the right of the names

This video may be of use to follow along.


If you couldn't find the default applications settings it may be because you are on a different version of android if that's the case you may also be able to find under just "Applications" in the settings menu

  • Sorry for posting this on the Web apps, didn't know there was an Android Enthusiasts. Edited the question for clarification. – K. Maglabe Feb 7 '16 at 3:51
0

You can also just uninstall the update of Google drive from application settings.

  • 1
    Not really. It would be nice if one could revert updates on downloaded apps from Application Manager, but our option is to uninstall completely on non-system apps. – Aaron Gillion Mar 24 '16 at 7:37
  • 1
    @AaronGillion, for an S5, Google Drive is a system app. It's a part of the OEM default GApps package. – Tamoghna Chowdhury Mar 24 '16 at 17:17
0

Install Firefox and download a PDF file, I'll ask you to choose a default app to open it, after that all PDFs will open on the app you select

0

Removed google drive and from playstation installed Google PDF Viewer. This then gave a choice after phone reboot of PDF Readers ... Chose Google PDF as Default and all is now perfect.

  • 3
    Did you really mean to say "playstation"? – Dan Hulme Feb 22 '17 at 10:33
0

This is what worked for me. None of the other well meant suggestions worked. https://productforums.google.com/forum/m/#!topic/chrome/u8xuBHFzHuo

In my case these instructions meant that I reverted to the older version of chrome that came with my tablet. When I clicked on a PDF file within that old version of chrome and was asked for my choice of viewer, I emphatically chose something non-Google, to be used every time. I was able to view the PDF file within my viewer of choice and got a PDF file in my download folder.

The step that I have to add to those instructions is that after following them I tried updating chrome to the latest version. The new choice of PDF viewer is still in place. So long as I never return to the Google viewer I should be able to change my default viewer again.

  • 1
    I was going to upvote this helpful answer but the editorial side-swipe below the line put me off it completely. I prefer answers to be factual, not the kind of thing you'd read in Reddit comments. – Dan Hulme Jun 2 '16 at 21:44
  • Thanks Dan. That means that this was factual? Google really does have tutus in the closet :-) – Indirect Pointer Jun 2 '16 at 23:11
  • 1
    Please include all steps rather than just linking – KCD Apr 3 '17 at 16:59
0

This worked for me.

Go Settings -> Application Manager(Applications) -> Tap Google Drive. Click Disable.

Now download a PDF. While opening that file, you will get an option to pick your default PDF Viewer. Choose Adobe and tap on always open with.

Now go back to the Application Manager and enable Google Drive.

enter image description here

0

Drive pdf viewer cannot be seen in apps > go >allapps> drive> afte doing all necessary clear defaults and set open links to ask all time

Disable drive and restart phone When you start all defaults will be gone and re enable drive

0

Go to Settings --> Apps

Select the app which uses Drive pdf viewer for PDFs by default. For example: ES File Explorer

Go to storage then tap on clear data. This has worked for me.

0

Go to Settings→Apps→ Drive→Permissions→Storage

Grant storage permission for Google drive.

IMG:

I solved my issue of not opening pdf.

0

I too had this problem. I use a Samsung note 2 and believe me the handset is not the issue nor is android. It was working fine.

Then it stopped and for every pdf downloaded through google chrome app it displayed whole pdf in drive but after storing it just didn't open in any other pdf viewer..said cannot be displayed,unrecognised format.

Solution

  • Uninstall all updates to google app and things go back to normal!!

Google is getting into a sick habit of giving so called updates to its apps and messing perfectly running things...wonder when they will realise difference between update and improvement.

0

Android 7.0 on Asus tablet.

I tried a number of options previously used but none worked on getting chrome to use the default pdf viewer previously set on the device (in my case, Foxit ...highly recommended for any small screen because it offers "word reflow")

I finally tried enough guesses and experiments that I think I got it.

  • Open the "default" android file manager named "File Manager" (which I had never used before)
  • Find a previously downloaded PDF file on your device and click to open it.
  • Choose your default reader in "File Manager"
  • Remember to tap "Always" before clicking the desired PDF reader icon
  • Subsequently, Chrome will open PDF files in your default PDF reader

Note, other File Managers such as ESFileExplorer offer the option to set "open with" but, while the ES setting worked for opening pdf files with most other apps, it did not work when Chrome opened a PDF file.

To test this, I went into;

apps/Foxit/OpenByDefault/Other/ClearDefaults

and following that downloaded a file using chrome and observed that chrome had elected to use it's default PDF viewer after clearing the foxit default/

Then, opened file manager again, completed the process again and it worked to set Foxit as the default PDF app as far a chrome was concerned.

Hope that this information is helpful to others as frustrated as this made it here.

0

For me, Google Drive is already not set as default for anything, yet the pdfs were being opened in Google Drive - and I have uninstalled the Google PDF Viewer. What worked - both on Marshmallow and on Oreo - is the following:

  1. Download some pdf file.
  2. "Try" to re-download it again - wait for the prompt that this file is already downloaded.
  3. Tap the file link in the prompt that appears, and choose the default app.
-1

I too was struck with this issue. Google drive hijacks the downloads, and then Adobe wants 9.99 per month ransom to get them out of there.

Uninstalling any Google Drive updates and then disabling it will also solve the problem...and without having to give up other advantages of the chrome browser.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.