2

I have a non-rooted Onyx Boox C67ML Carta running stock Android 4.2.2.

I just installed Orientation Locker. I transferred it from my phone using Shareit, but on my phone it had come from the Play Store.

Once installed, when I tried to run it, the whole device totally froze. See below for a picture of what it looks like.

When this device had frozen on me before, I had always been able to force a reboot by holding down the power button. That does not work in the current situation.

I carefully used a knife to take off the back cover to try and find the battery. The battery does not seem to be removable without physically breaking the device.

I suppose I could wait for the battery to run out. It was quite low when the incident occurred. It may actually be out already, and the device off, since e-ink screens may continue to display the last picture they showed when something goes wrong, even without power.

What should I do?

enter image description here

3
  • Shall we assume that USB debugging is not enabled in your device? For how long did you long-press the power button?
    – Firelord
    Feb 6, 2016 at 15:25
  • USB debugging was not enabled. The problem is solved too. I'm glad the battery was very low when it happened, otherwise I might have had to wait for quite a long time.
    – Fiksdal
    Feb 6, 2016 at 15:40
  • 1
    Oh and I didn't see the second question on your first comment: I pressed the power button for at least 30 seconds, far longer than what is usually required to force a reboot.
    – Fiksdal
    Feb 6, 2016 at 16:13

2 Answers 2

3

The device was not bricked. After a few hours I held down the power button again, and the frozen screen was replaced by the "no battery" screen. After charging, the device is back to normal. I caution users of this particular device not to use apps that try to force the systemwide screen orientation.

It was lucky that the battery was nearly empty when this happened. I suspect that if the battery had been more charged, the wait could have been significantly longer.

-1

Yes, that happened because you took the app from someone else from Shareit. You have to install any app from Play Store (Highly recommended).

Because when you take and install the app from someone else, if the DPI does not match, surely your device will stuck as soon as you open the app.

Ex. I have a Samsung Galaxy Tab 2, and I am taking an app from the Samsung Galaxy S2, and installing it on my device will get the device stuck. Not for every app, some will work perfectly.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .