1

the problem I am having is with Push notifications in Android. In order to receive my WhatsApp notifications I need to manually launch the application, which I don't want do. I want to be able to receive my notifications at any time...

I've heard that it might be due to the Push Notification not working so, I decided to download from Google Play the app PNF No-Root which changed the heartbeat interval to 5 minutes (I use WLAN connection) and it didn't work at all (the same for similar apps). I tried looking for other solutions. I went to Settings > Data Usage > WLAN > WhatsApp to check if the Restrict background data box was unchecked, it was unchecked. I also went to Apps > WhatsApp to see if the box "Show Notifications" was Checked. Went to WLAN > ADVANCED and set "Keep WLAN on during sleep" as "Always". Finally, I launched WhatsApp and all the settings are correctly set for me to receive, but I don't. When I go to Apps > Running > Whatsapp it says that there is 1 Process and to Services (although it shows 1 service sometimes), ExternalMediaManager and MessageService. My device is a Lenovo A5000 with Android OS 4.4.2 I don't know what else to try, thanks.

0

Do you have any power save mode set?

Otherwise Download the app "Wifi settings" and change the DNS Server to Google and hit apply . I hope this will help

  • Please link the app in your answer and highlight the specific capability of the app that would help OP- this would enhance the value of your answer – beeshyams Apr 4 '16 at 13:12
0

If you have any task killer app installed in your device, uninstall it or keep the WhatsApp app in the ignore list of that task killer.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.