4

I have sony xperia P device and I want to flash its ROM to get Marshmallow(I currently have android 4.0.4).

I want to do full backup of my phone before doing this, I knew about adb backup command, I installed android-tools from my Arch linux repos and issued :

adb backup -all -apk -shared -f momsmobile.ab   

it shows : Now unlock your device and confirm the backup operation. but Nothing shows at all, I have USB debugging enabled and tried to put a password the Developer option "Desktop password for backup".

I also tried following Arch wiki and added udev rules, this is the rule file :

SUBSYSTEM=="usb", ATTR{idVendor}=="xxxx", MODE="0666", GROUP="adbusers"
SUBSYSTEM=="usb",ATTR{idVendor}=="xxxx",ATTR{idProduct}=="yyyy",SYMLINK+="android_adb"
SUBSYSTEM=="usb",ATTR{idVendor}=="xxxx",ATTR{idProduct}=="yyyy",SYMLINK+="android_fastboot"

I'm sure the vendor's and product's id are correct(the real ones aren't provided for privacy).

the above didn't work too, I still get no confirm prompt, although when I issue adb devices I can see mine there.

Basically I have the same issue as this question, only this question has different device model(Sumsung vs Sony) and it's not answered.

Lastly I tried to disable all my antivirus protections, I'm using avast mobile security and disabled every thing but still didn't work.

So what's the problem ?

PS

I don't want to root the device(at least not on backup phase) and I don't want to use any apps.

4

Might be a little late, but here's what worked for me: put single quotes around the parameters.

adb backup '-all -apk -shared -f momsmobile.ab'
  • This worked for me. I think this is a bug; I'm using android-tools-adb version 5.1.1r36+git20160322-0ubuntu3 from the Ubuntu repos on Ubuntu 16.04.3, and adb version says Android Debug Bridge version 1.0.32. The version from developer.android.com/studio/releases/platform-tools.html (Android Debug Bridge version 1.0.39) seems to work fine without the quotes. – Hitechcomputergeek Sep 27 '17 at 13:45
  • Single quote didn't work for me on Windows computer. I used: adb backup "-apk -shared -all -system -obb" -f backup10032019.ab and it worked. – Sourav Ghosh Mar 10 at 8:58
1

I did it! I switched ON "USB Debugging(Security Settings)" in options 'For developers'. I have two options for usb debugging: 1. "USB Debugging" (simple) - this was always ON and 2. "USB Debugging(Security Settings)" - this was OFF.

Phone: Xiaomi Note 3 Pro SE (kate)

On yours phone options maybe will have different names.

  • I am using Redmi Note 4 Global. I did NOT have to enable "USB Debugging(Security Settings)". Just enabling the first USB debugging option worked for me. I used: adb backup "-apk -shared -all -system -obb" -f backup10032019.ab and it worked. – Sourav Ghosh Mar 10 at 9:01
0

On my LG G5 I changed MTP to RNDIS (USB Ethernet) in option "For Developers"; no quotes needed to get the Backup dialog. Thanks for the tip

protected by Community Jul 18 at 16:09

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.