3

I'm trying to use Tasker to turn on the do not disturb mode in android 6.0 marshmallow. I used to use tasker to make my phone go silent when I plugged in my charger cord every night, and turn off silent when I unplugged the cord in the morning. Tasker broke I think with Lollipop when we lost our silent mode. Now with Marshmallow we have do not disturb, but tasker can't seem to trigger it and/or has no access to "do not disturb." I set up a profile (state/power/any) and a "task" (audio/do not disturb/all) but it does nothing when I plug in my power cord. Can anyone solve this problem?

  • Your Tasker version? – Firelord Feb 7 '16 at 23:27
  • There very latest in play store. – spydie Feb 9 '16 at 0:00
4

It doesn't work because you designed the action not to do anything but let Android disturb you, as usual. Here's what each entry corresponds to under Audio → Do Not Disturb:

  • None: silences all sounds, including alarms - Total Silence
  • Priority: silences sounds except for certain calls or notifications - Priority Only
  • All: this effectively ends Do Not Disturb mode
  • Alarms: silences all ringtones & vibrations except alarms - Alarms Only

(Content partially derived from the article: Silence your device with "Do not disturb" - by Elena)

  • Tasker's Notification Access Service must be enabled for this action to work. Tasker suggests this at the first time setup of that action. Otherwise, enable it from Settings app -> Notifications -> Notification access -> tick Tasker. – Firelord Feb 18 '16 at 3:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.