2

When I plug the USB cable, the debug icon doesn't show up. adb devices doesn't see it.

  • Developer mode enabled.
  • Developer option enabled.
  • Stay awake enabled.
  • USB debugging enabled.

I am already in developer mode. Yesterday it showed up after insert sim card and reboot but this morning nothing.

I am using Debian 8 and debugging other devices has never been a problem.

I even tried rebooting the PC, and "hard" reboot the smartphone (letting the battery discharge completely) and start it again, but without success.

  • 1
    Have you tried with different USB cables and/or different USB ports and rebooting the PC? – Firelord Feb 8 '16 at 17:10
  • 1
    I tried different USB cables (known to work with other devices). Tried different USB ports. Plugging other devices on the very same PC always work except for the Nexus 5. I didn't try rebooting my PC but I will. – redochka Feb 8 '16 at 18:11
  • 3
    Have you actually turned on USB debugging? Simply turning on the "developer options" screen doesn't turn on USB debugging. The option for USB debugging is a couple of screens down. You wouldn't be the first person to get confused by this setting. – Dan Hulme Feb 10 '16 at 12:47
  • In usb connections settings is it set to charge only mode? – Bo Lawson Feb 13 '16 at 14:51
  • yes, i also tried mtp, ptp too. – redochka Feb 13 '16 at 17:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.