4

Just got a new phone, Droid Turbo 2. Used the stock messaging app. Whenever I get a text with the phone unlocked, the whole text displays in a drop down box that pops up at the top of the phone.

I previously had a Droid Maxx and on that, the text would display in the status bar at the very top and would scroll one line at a time through the message.I would prefer that, but all that really matters is that I DO get a notification, and that it DOESN'T display the text over whatever I'm doing.

I have tried adjusting the phone settings , I also tried to adjust the individual app notification settings and the messaging app settings... Nothing changes it. I have seen on multiple other posts, an option somewhere to "disable text message preview" but that option does not exist in any of those places for me. There HAS to be a way to stop this on the stock phone without downloading ANYTHING.

2

I tried this on my Nexus 6P and Android 6.0.1 version

Under "Sound & notification" -> "Notification" tab

  1. Set "When Device is locked" to "Hide sensitive notification content"
  2. App Notifications ->
    • Select "Messenger" (or the app which you want to hide notification).
    • Disable the option "Allow Peeking".

This worked for me.

  • Don't have the option. – Shane Smith Feb 11 '16 at 17:52
0

settings->apps->notifications. you can block or unblock notifications when screen is on or off. this the thing on my nexus 5x

0

they call it peeking! for example to stop this behaviour happening in the hangouts app for android 7

go to notifications -> all apps -> hangouts -> show silently (switch to on)

This stops a message coming up in the middle of doing something but allow you to get a LED notification (if left switched on) and also a new message icon

-1

You could try a 3rd-party messaging app like Textra SMS, which allows you to customize notifications via "Customize Notifications", particulary the "Floating Notification" setting.

  • As I said, NOT looking to download anything. – Shane Smith Feb 10 '16 at 6:35
-1

go into the message app --> settings --> notifications --> turn off "pop-up display" and "preview message"

Cheers!

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.