2

I installed kingroot and tried it, I closed it thinking it finished and rebooted my phone.

After reboot root checker says I have su binary but not root access.

My problem is I can't find kingroot, not in launcher nor in Settings->apps it doesn't appear anywhere yet when I install it from apk it doesn't say "Install" but "Replace", I tap on replace and wait until it says "application install failed".

I want to remove it completely But I don't find it , how do I uninstall it ? and if I can't find it then how the packaging tool detects it's installed ?

my phone is sony xperia P with android 4.0.4.

EDIT :

I have found Kinguser.apk in /system/app not /data/app so That's why I can't find kingroot, it installs itself as system app(and apparently sets some permissions to not allow me to even see it)

So I need root to uninstall it, unfortunatly when I try su in terminal I get this :

[-] Connection to ui timed out.

So what to do?

EDIT 2

Ok after I rebooted I can find kingroot in my Settings->apps->all now for some reason, I can disable it but not remove it (because As I said it has installed itself as system app).

  • Can you flash a custom recovery or do you have one? It would be easy to remove Kingroot using a custom recovery. – Firelord Feb 9 '16 at 18:32
  • @Firelord I don't have custom recovery, is it a ROM ? if it is then I can't flash it as that needs root(right?) and I can't root. – niceman Feb 9 '16 at 20:52
  • You can use ES File Explorer to delete it from the system/apps folder. Then goto android settings and remove it from the device administrators. Now you can uninstall it – dmSherazi Sep 1 '16 at 7:39
  • I have to factory reset to remove the MALWARE kingroot and kinguser. – f01 Sep 17 '16 at 20:41
2

Install kingroot again restart your phone, install system app remover application and use it to uninstall kingroot. remover

  • I can't install it again, As I said in my post it refuses to install – niceman Feb 9 '16 at 14:29
  • OP wrote: "root checker says I have su binary but not root access". If root privilege cannot be gained then I don't think the app you linked would prove to be helpful. – Firelord Feb 9 '16 at 18:33
  • which file explorer are you using – Frrank Feb 9 '16 at 19:45
  • @Frrank file expert 6, why do you need this info ?!!! if you want me to manually uninstall it then I'm afraid I can't because it needs root access which I can't gain – niceman Feb 9 '16 at 20:54
0

Try attempting to use different uninstaller apps to locate and remove the application.

KingRoot is a system app, so you will need a system app uninstaller, such as Jumobile System App Remover (which worked for me).

Try using a different launcher (this sounds weird, but in my experience some apps bind to launchers in strange ways...)

Try using a different rooting app, if possible, and going from there.

If none of these work, more drastic action might be needed.

  • whatever uninstaller there is I must have root access because kingroot is considered a system app and I can't gain root – niceman Feb 9 '16 at 20:57
  • I might try different rooting app but after I completly remove kingroot as I think whatever that app is kingroot will interfere with it – niceman Feb 9 '16 at 20:58
  • If only I can "su" like I do in my arch linux then I can do whatever I want – niceman Feb 9 '16 at 20:59
  • You might just have to reflash a stock firmware. I know this doesn't sound ideal, but if this is something you really need done, that might be the only way to do it. – Verdant Drift Feb 9 '16 at 22:28
-1

Solved the same problem. You said you have disabled it. Just ENABLE it back!!! And you have root access again!

  • thanks, I have solved the problem long ago by flashing the rom, I didn't post that as an answer because technically I was looking for solutions other than "format" so technically this isn't an answer – niceman Jun 26 '16 at 18:14

protected by Community Jun 26 '16 at 6:54

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.