I had fingerprint set to lock Samsung Galaxy S6. I don't remember ever setting a backup password - screen literally locked as I passed the phone to someone.

I managed to access the phone signed in on Google. Then the phone requested I set up another fingerprint lock, which I did. I also put a password in, which I remember. But the password is not being recognised, and the phone is locked again.

  • I tried all combinations of all passwords I have, but no luck unlocking the phone
  • Samsung's Find My Mobile and Android Device Manager not letting me access phone/reset lock (perhaps because the remote control is not enabled)?
  • Unable to install the lock bypass app as it's saying the app is not compatible
  • Unable to use ADB
  • Tried installing 3rd-party apps to unlock the screen, but they don't work

Desperate to sort this out before I do a factory reset. Samsung Service Centre didn't really help, they said factory reset is the only option.

Any suggestions on how to unlock the phone (or do a data backup before I factory reset) would be great.

  • Do you have access to your notification drawer? Feb 13, 2016 at 22:03
  • Hi, no I'm unable to access it
    – amjama
    Feb 14, 2016 at 8:51
  • Do you see any type of clickable notification from Play Store when installing an app? Like "XXX has been installed" that you can tap on to launch it in the background? Also, what carrier/network you're on? Feb 14, 2016 at 12:39
  • Hi again, and thank you for helping! When I install an app the notification states that it has been installed, but I can't click on it...it still asks for the backup password.
    – amjama
    Feb 15, 2016 at 16:04
  • i'm on a dubai carrier
    – amjama
    Feb 15, 2016 at 16:04

2 Answers 2


Following the guide submitted by Aaron Gillion, when I arrived at the step "6. Go into adb shell type su hit enter" all I kept receiving was:

CANNOT LINK EXECUTABLE DEPENDENCIES: library "libc.so" not found

I fixed it via TWRP → File Manager. I navigated to /sbin/libc.so to confirm the file exists, so SuperSU was installed correctly.

So, instead of running the commands:

rm /data/system/gesture.key then rm /data/system/password.key

I went to TWRP → File Manager, navigated to the location /data/system/ and deleted the fingerprint.key and password.key files

  • Good call, you can delete those files directly from TWRP or Aroma File Manager in Philz Touch. Feb 23, 2016 at 22:10
  • I can't even run adb shell it pops out 'CANNOT LINK EXECUTABLE DEPENDENCIES: library "libc.so" not found' Feb 18, 2018 at 2:43

Figuring out whether you can go all the way and bypass your lock screen will depend on the outcome of the steps below.

Following this guide,

  1. Skip the step of turning on USB Debugging, you can't get past the lockscreen.
  2. Download Odin, and the TWRP .tar file
  3. Boot your phone to download mode, then plug it in to your computer, let the drivers install. Open the Odin.exe on your computer, fiddle with the USB connection until Odin says "COM1/2/3/4: Connected!"
  4. Put the TWRP .tar file in the correct textbox, uncheck Auto-Reboot
  5. Flash!
  6. When it says finished, you can reboot your phone. However! You need to boot it directly into recovery mode, otherwise TWRP gets overridden past the Samsung logo.
  7. Once you're in TWRP, congrats! Make a FULL backup onto an SD card or USB drive with OTG adapter.

Now to bypass your lockscreen:

  1. Flash the SuperSU .zip found in the guide.
  2. When you boot into TWRP does your computer recognize the phone in Device Manager? Does it make a bloop sound? You should find a device called "ADB".
  3. Download the ADB kit from here (and the drivers if you can't get your computer to install them) and call adb.exe from a command prompt.
  4. Run adb devices. If you see a long 50-character ID pop up, you're in luck!
  5. If there's no ID, try another computer, it took me 5 computers to recognize.
  6. Go into adb shell type su hit enter.
  7. If it says permission denied, you're out of luck.
  8. Run rm /data/system/gesture.key then rm /data/system/password.key
  9. If no errors, profit!
  10. If permission denied, remount system RW: mount -o rw,remount /system If that fails, try mount -o rw,remount /proc /system (a little hack I came across) and try step 8 again.
  • User kumepro had this to add: "you have to also delete 3 files also "locksettings.db" "locksettings.db-wal" "locksettings.db-shm".
    – Firelord
    Jan 4, 2019 at 10:34

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .