1

OS: OxygenOS version 2.2.0
Android version: 5.1.1
Phone Model: ONE 2005 [OnePlus 2] (Build number: One A2005_14_151211)

When I connect to a Secured Wifi network that requires that I "Accept" some sort of agreement, normally I would click on "Sign into Wi-Fi Network", which pops up on my status screen and then I would "Accept" the agreement. Now when I click on "Sign into Wi-Fi Network", all I see is a screen with a big circle around a lock. I can't tap on anything on this screen, except exiting out. If I exit out, I am taken back back to my homescreen and not connected to the internet. All that happens is that "Sign into Wi-Fi Network" appears in my status screen again. If I click on it again, I go right back to the lock screen.
I feel stuck in this:
for (a = 0; a < wifisuccess.length; a++) {
I can't be the only 1 having this problem...Or maybe I am? Any insight would be much appreciated.

Thank you!

================

UPDATE:
(First of all, I now realize that I can't type Javascript code as a joke and have it show up properly. I also learned that I need to add Line breaks if I want things to show up. Good to know. If you're confused, the above code was supposed to imply a LOOP on my situation..har har har.)

Upon further investigation, I saw Option Dots on the top right on that screen with the big lock on it [DUH!]. I tapped the Option Dots, which brought up a menu with the following 2 options:

  1. "Do not use this network"
  2. "Use this network as is"

I selected "Use this network as is"

After doing this, I am taken back to my home screen as before. This time, the "Sign into Wi-Fi Network" option is no longer on my status screen and I am still not connected to the internet when I tried to access my email, Facebook, etc.

0

SUCCESS! I did the same steps as I mentioned in the Edit to my Question:

1. Touch "Sign Wi-Fi Network
2. Touch the Option Dots
3. Touch "Use this network as is"

I then did 1 additional step:

4. Manually open a browser window (Chrome)

and SUCCESS!

5. Now I was given the screen where I was able to "Accept" the terms and log into the network. Internet for all Apps/items on my phone now worked.

[Note: After this worked, I rebooted my phone and tried doing the above steps again to make sure this solution worked again and it does.]

I feel like somewhat of a bonehead for not noticing the Options Dots, but the fact that I have to manually open a browser after connecting to the network was a valid thing for me to overlook.

Hopefully this solution helps someone in the future.

protected by Community Aug 7 '17 at 15:16

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.