I am using One plus two. But it is not connecting to my system. It used to connect previously. But once i set it on Charge only mode. since then there are no options in the notifications bar to transfer the matter from phone. I have tried all the steps explained, even the clicks on build number. But nothing helped me out USB debugging option is saying Device is in charging mode, USB Debugging is disabled. and i tried all the ways to enable it, but it is not letting me do it. and when i click on three dots in the storage, and click on USB connection settings it says connect your device to computer to access USB connections, even when the device is connected. Please help me out to solve the problem

  • The first debugging steps are always: try a different USB cable; try a different USB port on your PC; try a different PC if you have a friend.
    – Dan Hulme
    May 2 '16 at 6:53

With the latest Cyanogen update, soon after connecting to the pc, a notification appeared on my phone 'USB for charging'. I clicked and changed it to 'USB for file transfer'. Then I could browse A0001 and transfer files!


I had the same issue, and, after the following steps, it seems to have worked itself out.

  1. Disconnect the device from my PC
  2. Go to Settings > More > Tethering & Portable Hotspot
  3. Enable USB tethering
  4. Disable USB tethering and Wait several minutes
  5. Reconnect the device to my PC

After that, the USB Debugging option under Developer Settings was no longer greyed out.


This problem arose after I turned the developer options on. So for once just disable USB debugging and enabled it again and the problem was solved.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.