First time that I've been lost about how to fix an android device. In short, I tried updating the my device to the latest cm13 nightly but that ended up causing the Google logo loop (wouldn't boot into animation). I tried various fixes that I know of (tried reflashing with new Gapps, tried flashing a stock ROM no luck).

My issue now is that I can't use 'fastboot' anymore as my device isn't being recognised and so wondering if there is a fix that can be applied from twrp recovery itself.

Also must mention that device has been rooted (though not sure if it still is as I can't boot into a ROM) & has an unlocked bootloader (which can't be locked either).

Thanks in advanced.

  • You should still be able to enter the bootloader where fastboot will work with buttons. While the 5x is off hold volume Down + Power button at the same time. – Bo Lawson Feb 14 '16 at 18:31
  • @BoLawson i can get into bootloader but the fastboot still isn't working. I've tried a reflash of a custom ROM again (this time with the vendor file) no luck still. Could this be a driver issue then? adb works though not sure if i can do anything with that? – Kristopher Rahim Afful-Brown Feb 14 '16 at 18:35
  • If adb works then fastboot should work. But fastboot only works in the bootloader. Once you move past it to recovery or the OS then it is ADB. Have you tried a factory reset from recovery sometimes that gets the OS working. – Bo Lawson Feb 14 '16 at 18:46
  • @BoLawson tried and failed. I am going to try flashing the previous cm13 ROM i had installed before the issue occurred – Kristopher Rahim Afful-Brown Feb 14 '16 at 18:57

Get into Recovery, if you flashed a CM13 you probably have a custom recovery installed. Do a factory reset from your custom rom. Alternatively, you can wipe Cache, Data, System individually.

After this, try rebooting to bootloader and connect your phone to a different PC if your's doesn't recognise the phone. It is preferable if the PC has Linux as it doesn't get you in device driver hassles. If anyway you have no option other than a Windows system, install universal naked drivers if your own device's official drivers doesn't work. Reboot your system and connect your device again to try getting Fastboot mode.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.