I need your help. My son locked my Huawei Ipad and he doesn't know what patterns he used and I can't log in on my Ipad, I tried everything, if there is anyone who knows, please help.


Method 1: If you know your Gmail userId and password

  1. Draw incorrect patterns for 5 times.

  2. When you have tried 5 times, you will get a message that you have drawn the pattern to unlock your android phone for 5 times so try it again after 30 seconds.

  3. After 30 seconds, "Forgot pattern” option will appear.

  4. Tap the Forgot pattern option. Enter your gmail username and password which is linked to your device.

  5. Now you can reset your lockscreen security.

Method 2: If you don't know your Gmail userId and password

This will reset your device and you will lose all data. [Data that is present in internal storage will be erased]

  1. Follow this answer to get into recovery mode and factory reset your device.

Method 3: If USB Debugging is Enabled.

If you are an advanced user, you might know what USB debugging is and how to send commands through adb.

Pre-Requisite: USB Debugging must be enabled previously before phone is locked

  1. Install Minimal ADB and Fastboot on your PC.

  2. Install USB drivers for your model. List of drivers can be found here: OEM Drivers

  3. Connect your tablet to the PC and open Minimal ADB and Fastboot application on your PC.

  4. Type : "adb devices" and press enter. This will show list of devices currently connected to the PC. If drivers are properly installed, this will give some result like, enter image description here

  5. Finally run : "adb shell rm /data/system/gesture.key" to remove the pattern lock. Now enter any pattern in your tablet and it will get unlocked :)

  • 1
    Don't you need root to rm gesture.key? – Aaron Gillion Feb 15 '16 at 17:09
  • "adb shell rm /data/system/gesture.key" -- this would never work unless adb daemon is running with root permissions. Method 1 is of no use to Lollipop and above Android versions. See Where has the forgotten password button gone? Method 2 has faults because the answer it links to uses Vol Up + Power key combo which is not the combo used in every (or most at least) device to boot into recovery mode. – Firelord Feb 15 '16 at 17:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.