3

There is a contact in my contacts which can't be found by name in dialer, but if type her number in the dialer the name appears. All my contacts are stored in my Google account.

How can I solve this issue?

My phone uses Android 7.0 (Samsung Galaxy Note 5)

  • Android version is wrong just so you know. Some versions don't get non-English characters like ş, ç, ğ, ö, ı, İ or ü etc. – SarpSTA Feb 16 '16 at 10:21
  • Edit the contact where you can find it. Change name to English, if it uses rare characters. – NVZ Feb 16 '16 at 12:12
  • The problem is the names are in English.... – Amir Pashazadeh Feb 17 '16 at 17:39
4

I had the same problem with Huawei P10, but it seems I could solve it. Within "Contacts" there is an option called "organize contacts" and within that "Rebuild index data". I tapped on it and when rebuilding completed (within a couple of minutes) the feature of getting a list of contacts as a string, contained by their name, is being typed in worked again.

0

Check if you has enable the option "All contacts" in Contacts to display.

To check this, open the contacts. Select the three dots on the top right, and select "Contacts to display". Here you can select what contacts account you want see in your contact list.

Verifiy if your phone contact is here and later search with the dial.

  • The contact exists in the contacts app, but can not be accessed using the dialer... – Amir Pashazadeh Feb 16 '16 at 22:32
  • Ok, but the dialer app search in your contacts and registry calls/sms. Try to apply these changes, and tell what happens with your search. – molblin Feb 16 '16 at 23:33
  • There is no 'contacts to display' option in my Samsung S7. This is very annoying feature. – iiro Sep 13 '16 at 8:04
  • @molblin oh i found the setting I have set the "all contacts" option on, still, the dialer cannod find certain contacts – iiro Sep 13 '16 at 8:10
0

I have the same issue. Example: I have a dozen "Adam"s in my contacts, but the dialer won't find them. The only workaround I found is to type "Ádám" or something similar with strange vowels, then it finds them. (I have a Vodafone Smart Prime 7 with Marshmallow, and I have two languages set up in google keyboard, never had this with earlier android versions or different phone.)

0

Try to un-link contacts and it will show them.It is something broken when you link some contacts from different sources and accounts. Could not find a pattern but this solve the issue.

0

i had the same problem in my Le Eco 2 phone and i just did very simple thing 1st export all your contact to phone storage then delete all your contacts and them import back all contacts from your phone storage. This worked for me and i believe it will work in all android phones.

0

I myself had the same problem with my Huawei P10. Read some answers and found, in the Contacts section the 3 dots in the right lower corner of the screen. Pressed them and then again pressed Organise Contacts. There you will find the last option - Rebuild index data. By selecting that option I fixed my problem. Great for all my contacts to be back in the Dialer !

protected by Community Mar 2 '18 at 3:16

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.