7

Recently I upgraded my Moto g(Second gen) to android marshmallow. But after that my Contacts app is not displaying any contacts and call logs. What i am getting is one blank screen only. I tried installing other apps like contacts + , true dialler etc. But same result. Infact contacts plus is not launching only. Its getting stuck while launching. So , after marshmallow update my phone is of no use , because I cant make any calls , see my call logs etc. Is this a bug with marshmallow? Any solution for this issue? Thanks in advance.

  • This is probably due to a bad update. You may need to flash Android Marshmallow manually to get rid of this problem, or take the device to a service centre where they will flash it for you. – Tamoghna Chowdhury Feb 17 '16 at 12:44
  • Somehow I fixed the issue. I followed this link . I wiped the cache partition and after reboot I exported contacts from google contacts as vcf file , then imported using contacts app. Now issue is fixed! – user3339689 Feb 17 '16 at 13:02
  • Please add the steps you followed as an answer. – Tamoghna Chowdhury Feb 17 '16 at 13:02
3

I could fix this issue by doing the following steps.

First Wipe the Cache partition. (It won't erase any files or settings)

To wipe the cache partition do the following steps.

  1. Ensure the device is powered off, and unplugged
  2. Press and hold the Volume Down button and Power button (located on the right edge of the device) for approximately 3 seconds then release.
  3. From the "Boot Mode Selection Menu" screen, select Recovery.

    Note: Use the Volume Down button to scroll through the menu options and the Volume Up button to select.

  4. From the "No Command" screen (Android figure lying on his back), press and hold the Power button, tap Volume Up once and then release the Power button.
  5. Select "wipe cache partition". Note: Use the Volume buttons to highlight and the Power button to select.

  6. "Reboot system now" will be highlighted, press the Power button to select it.

    Note: Allow several minutes for the reboot process to complete.

Once you are done with the Wipe procedure , go to https://contacts.google.com and export your contacts as .vcf file and copy to your device.

Open Contacts App (Phone app) -> go to options on the top right corner (3 dots) -> choose import/export -> import from .vcf file. This will restore your contacts..

  • 1.wipe cache 2.Reboot system now 3.Reboot to safe mode This option is really working ...thank u brother... – user175433 Jul 9 '16 at 4:06
  • I tried wiping cache and it didn't seem to work (but it is possible that I simply didn't wait long enough for the contacts to re-appear) so I tried wiping the dalvik cache and that worked. (Just as a tip if someone is experiencing the same issue. Just wiping the cache, deleting the dalvik cache doesn't destroy any data on your phone) – Christoph Nov 14 '16 at 3:42
0

Make sure your device's screen is on, then press & hold the Power button. In the box that opens, touch & hold Power off. You’ll see a “Reboot to safe mode” box. Touch OK. Your device will start up in safe mode. go to contacts tab all contacts will update automatically then again reboot the device and you will be able to see the contacts in normal mode.

0

I found a simple solution... Remove the google a/c first... Then set up the google a/c again... Go to contacts' setting & set contacts display as your google a/c... this time the sync will be as per the google a/c and all invisible contacts not found during search will be visible...!

0

I found another solution..that works for me... restart your phone in safe mode, open contatcs app...you will see ur contacts list loaded without any delay...now switch off ur phone and restart it in normal mode..everything works fine..

0

On Moto G new Marshmallow doesn't allow to save contacts to phone accounts. (Device) ... you can save your phones numbers to google acc and during the adding process of new contact- there is no options to select the the place where u actually want to save new contact. Like it used to be in previous version of android. for instants -- sim, phone, card, google acc.. By this way android try to own you , your contacts and all information about u.

0

It's very simple Press contact icon and drag it to app info Then go to permission and enable all options (storage) Then it will work

0

Go to Settings - Contacts - Contacts to Display Select All Contacts

This worked on my Oppo r9 plus with Android 6

-1

I think the problem is phone number format, Phone apps use format "+XX XXX-XXX-XXX" so contact with number format "+XXXXXXXXXXX" will not displayed.

I fix all my address book with apps called Twitch! https://play.google.com/store/apps/details?id=angel.twitch

After fixed my call history shown address book name, not numbers.

  • 2
    I hate to seem suspicious, but is this an app you're affiliated with in some way, or are you recommending it as a happy customer? We get spam on this site sometimes so we try to make sure it's clear when recommendations are genuine. – Dan Hulme Apr 7 '16 at 16:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.