I have a Samsung Galaxy Tab 3 (GT-P5210GNYXAR) currently with NO OS (I completely wiped the tablet in TWRP.)

However, I did root the device, so now it has the TWRP thing. I tried installing the superSU OS I used to root android OS, no luck. I have not tried reinstalling the factory OS because the download time takes 2 hours.

I'm trying to install Ubuntu onto this tablet with a windows computer (that's for a different question) but fastboot devices doesn't show the tablet. adb devices does, however it says it is "unauthorized" and I don't know how to authorize it without an OS.

Is there some TWRP-specific program or something?


I tried downloading the stock rom from a website however the download was too slow (because I'm not paying for premium) and the download failed. However, I will retry tomorrow and use Odin or Heimdall.

  • For the fastboot command to recognize a device, are you booted to the devices bootloader? – DukeSilversJazz Feb 19 '16 at 19:44
  • You can't access fastboot devices from TWRP. You need a key combination to get to download mode for that. – Aaron Gillion Feb 19 '16 at 23:56
  • 1
    There's no fastboot mode in Samsung devices. – Manubhargav Feb 20 '16 at 3:43

SuperSU is not an OS, it's a binary (and associated app). As RMarkwald indicates only adb can interact with Recovery (whether TWRP or otherwise), fastboot is for interacting with the fastboot mode. You will need to boot into fastboot mode to flash a ROM via fastboot.


If its a Samsung, you might consider looking into Heimdall:

Heimdall is a cross-platform open-source tool suite used to flash firmware (aka ROMs) onto Samsung mobile devices.

I've personally had success with it

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.