1

I just updated my tablet (Galaxy Tab Pro 10.1) to the latest CyanogenMod 12.1 snapshot, via the built-in updater. It worked perfectly, and booted into my homescreen just fine. I decided to factory reset it because I had some issues with Google Play, but when it restarts, it shows the tablet's logo, then flashes the TeamWin logo, goes black for a split second, then shows the logo again. I waited a few minutes, but it doesn't stop that loop.

I tried restarting, then getting into recovery mode by pushing Power + Volume Down (as well as Power, volume up and the home button, and various combinations of that), but I can only get into the screen where it says "Downloading... Do not turn off target!!".

I've tried to look this problem up, but nearly all the suggestions involve getting into the recovery, which doesn't seem to work. This is probably a terrible question, but I'm unsure on how to proceed here, without making it worse.

I've tried plugging it into a laptop, and booting it into that download screen while it's plugged into a laptop, but that doesn't change anything. Do I need to reinstall TWRP in some way, then install CyanogenMod from scratch somehow?

0

I got the answer.

I installed Odin, then flashed the correct TWRP archive, from Download mode. When it restarted, it booted into CyanogenMod without any issues. I will only need to install GApps again because I did a factory reset, but that isn't an issue (I hope). I can only assume that the update messed up TWRP, causing it to loop.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.