2

a few weeks ago I updated the Google Play services of my Oneplus One (Android version 5.1.1, Cyanogen OS version 12.1.1). From an apk that I downloaded online. Since then it keeps crashing. Sometimes every few minutes but sometimes also multiple times per minute. I can still use the internet but my instant messaging apps seem to receive messages with a delay. Probably because the push service of GPS is not working properly.

The crashes especially occur when connecting to a wifi, using other apps that connect to internet and sometimes also when writing text messages (SMS)

I didn't set up a Google account and disabled almost all my Google apps except for Google One Time Init, Google Play services, Google App and Google Services Framework. (because disabling them caused some problems).

The Permissions for Google Play services switched off, especially the Location permission was denied very often (~ 62000 times). Wake up, Keep awake and Auto start are allowed.

My phone is not rooted.

Google Play Services versions:

previous version: 7.5.71 (1955121-438)

current version: 8.4.89 (2428711-270)

I also tried version8.4.89 (2428711-438) from xda-developers but could not it install due to Parsing error.

This is the error message that shows up in the crash report.

java.lang.RuntimeException: An error occured while executing doInBackground()
at android.os.AsyncTask$3.done(AsyncTask.java:304)
at java.util.concurrent.FutureTask.finishCompletion(FutureTask.java:355)
at java.util.concurrent.FutureTask.setException(FutureTask.java:222)
at java.util.concurrent.FutureTask.run(FutureTask.java:242)
at java.lang.Thread.run(Thread.java:818)
Caused by: java.lang.UnsatisfiedLinkError: dalvik.system.PathClassLoader[DexPathList[[zip file "/system/framework/com.android.location.provider.jar", zip file "/system/framework/com.android.media.remotedisplay.jar", zip file "/data/app/com.google.android.gms-1/base.apk"],nativeLibraryDirectories=[/vendor/lib, /system/lib]]] couldn't find "libgmscore.so"
at java.lang.Runtime.loadLibrary(Runtime.java:366)
at java.lang.System.loadLibrary(System.java:988)
at com.google.android.gms.org.conscrypt.NativeCrypto.<clinit>(SourceFile:53)
at com.google.android.gms.org.conscrypt.OpenSSLContextImpl$TLSv12.<init>(SourceFile:152)
at com.google.android.gms.org.conscrypt.OpenSSLContextImpl.getPreferred(SourceFile:55)
at com.google.android.gms.common.net.SSLCertificateSocketFactory.a(SourceFile:272)
at com.google.android.gms.common.net.SSLCertificateSocketFactory.a(SourceFile:292)
at com.google.android.gms.common.net.SSLCertificateSocketFactory.createSocket(SourceFile:552)
at com.android.okhttp.Connection.upgradeToTls(Connection.java:175)
at com.android.okhttp.Connection.connect(Connection.java:155)
at com.android.okhttp.internal.http.HttpEngine.connect(HttpEngine.java:276)
at com.android.okhttp.internal.http.HttpEngine.sendRequest(HttpEngine.java:211)
at com.android.okhttp.internal.http.HttpURLConnectionImpl.execute(HttpURLConnectionImpl.java:382)
at com.android.okhttp.internal.http.HttpURLConnectionImpl.connect(HttpURLConnectionImpl.java:106)
at com.android.okhttp.internal.http.HttpURLConnectionImpl.getOutputStream(HttpURLConnectionImpl.java:217)
at com.android.okhttp.internal.http.DelegatingHttpsURLConnection.getOutputStream(DelegatingHttpsURLConnection.java:218)
at com.android.okhttp.internal.http.HttpsURLConnectionImpl.getOutputStream(HttpsURLConnectionImpl.java:25)
at com.google.android.gms.checkin.k.a(SourceFile:366)
at com.google.android.gms.checkin.k.a(SourceFile:238)
at com.google.android.gms.checkin.g.a(SourceFile:711)
at com.google.android.gms.checkin.g.doInBackground(SourceFile:678)
at android.os.AsyncTask$2.call(AsyncTask.java:292)
at java.util.concurrent.FutureTask.run(FutureTask.java:237)
... 4 more

Does anyone have an idea how to solve this problem? Before the update my phone worked fine. Did I install the wrong version of Google Play services? Or do I need to setup a Google account?

  • I don't know many places online with good apks. But this one is pretty well [apkmirror.com/apk/google-inc/google-play-services/] and I trust their apks. – KhoPhi Feb 21 '16 at 21:44
  • @Rexford, thanks for the tip! I just downloaded and installed Google Play services again and it seems that the crashes stopped :) – arne.z Feb 21 '16 at 22:00
  • So from now on, you know where to download your apks @Onion (sorry, I don't have your letters on my keyboard, but nice username!) – KhoPhi Feb 21 '16 at 22:02
1

One of the good places to downloaded your APKs are from APK Mirror (run by Android Police).

It is important to download your APKs from trusted sources for safety. In your instance, the apk is probably faulty, and as a result, giving you the errors.

  • That solved the problem! The version I installed was the wrong one for my phone. Version 8.4.89 (2428711-248) from APK Mirror is working for me, and I guess any other Oneplus One! – arne.z Feb 22 '16 at 11:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.