0

I have a HTC One M7 since 2 years. I got a software update in December and i tried to update it and somehow after the update the phone showed me errors. So back then i did a recovery and the phone went back to the previous configuration. After this I avoided this update totally. But recently i totally ran out of battery and when i charged it, and started it, it upgraded automatically and now it is stuck in the HTC One white screen. Now if i want to recover it, it gives me the following errors -

E:missing bitmap oem_unlock_bg (code-1)
E:missing bitmap oem_unlock_bg_yes (code-1)
E:missing bitmap oem_unlock_bg_no (code-1)
E:missing bitmap icon_ruu (code-1)

Write host_mode success

handle_cota_install: Can't mount /sdcard, 1 times
handle_cota_install: Can't mount /sdcard, 2 times
handle_cota_install: Can't mount /sdcard, 3 times
handle_cota_install: Can't mount /sdcard, 4 times
handle_cota_install: Can't mount /sdcard, 5 times

I tried most of the solutions i could find. Did a cache wipe, even did a factory reset by pressing the power button and the Vol down button for some time. After the factory reset it gets stuck in -

htc one m7 stuck in android is upgrading Starting Apps

How can i fix this? It has been 2 days and I am trying to get it up and running with no success. Any help is deeply appreciated.

  • 1
    It sounds like it is time to get the official RUU and reflash the device. – acejavelin Feb 23 '16 at 14:51
  • Need more details: is the bootloader unlocked? Do you have custom recovery? What's your carrier? What is/was the ROM version you were running and what was the upgrade to? If you can post a screenshot of bootloader screen or just tell us what is shown at top of that screen. – Paul Ratazzi Feb 23 '16 at 14:52
  • When i do a hard boot it tells me Locked. I am not sure how can i find that i have a custom recovery or not. My carrier is o2-de. How can i find the ROM version from the Hard boot screen? The top of the screen shows locked and data such as - M7UL PVT SHIP S-ON RH, HBOOT-1.61.0000, RADIO-4T.35.3218.16, OpenDSP-v35.120.274.0718, OS-7.18.206.51, eMMC-boot 2048 MB – Dan Feb 23 '16 at 15:16
  • @Dan You can unlock the M7 without it being bootable, it doesn't have the OEM Unlock security (I believe, been a while since I had one). You shouldn't need to unlock to RUU as long as you are using the same or higher version of firmware. – acejavelin Feb 23 '16 at 15:20
  • @acejavelin - How do i unlock the bootloader? I found a process in the HTCDev website. is that the process? – Dan Feb 23 '16 at 15:23
1

You need to run/flash the official RUU file from HTC that either matches your device's current firmware level or is newer. This will rewrite the partition table, and all data on the device back to factory condition. If that does not work to bring the device back into service, you will likely need to send it in to HTC or replace it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.