I've just arrived at some place which offers wireless internet. When I try to connect my computer, it sends me to some specific URL in which I need to accept some terms of use, and then the Internet works fine. When I try to connect to that network with my Android, however, it's stuck on the "obtaining IP address" stage of the connection for long minutes.

After a few tries, it just gives up and moves that SSID to a "disabled" status - which I haven't seen until now - in which it is remembered but it doesn't attempt to connect to it.

I can't navigate to any special address on the device's browser because it outright refuses to connect to the network.

How can I solve this issue?

2 Answers 2


The issue is not with your device but with the wireless provider. That is the typical behavior when connecting to a defective hotspot, either over capacity or just a tad too far for a reliable connection...

Sadly there is nothing you can do about it. It happens a lot to BT hotspots in the UK, in London most of them are overloaded during working hours.

  • I tried again this morning and this time it worked - which reaffirms your answer, since nothing changed on my end, but maybe there is now less load on the hotspot. Thanks!
    – Oak
    Commented Sep 24, 2011 at 12:27

This exact symptom can be fixed by changing permissions on


to execute on all accounts: user group and others

As mentioned here

You need rooted device and root browser.

Hope this helps any fellow Googlers

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .