I'm trying to root my Motorola Droid RAZR HD running Android 4.4.2, and I can't find any working instructions anywhere for how to root it. I've looked over the XDA Developer forums, but many results assume that the phone is already rooted.

I've made sure that all Motorola drivers are updated on my computer, as well as having developer mode unlocked on the phone.

I've tried following the XDA thread here: http://forum.xda-developers.com/showthread.php?t=1943851, and when I run the run.bat file, the console either gets stuck on "Waiting for device" or "daemon started successfully", after which nothing happens. I've left both results running for >30min, with no results.

Is there something I'm doing wrong here with this guide, or is there a better/simpler way to root the phone? Also, do I need to factory reset my phone prior to rooting for best results, or can rooting be performed on a used phone?

I have checked the rooting index, and the Droid RAZR HD isn't indexed.

EDIT: I have been informed by Tamoghna Chowdhury that the above link is for Android 4.0 ICS, not 4.4.2 KitKat.

  • Is the phone showing USB Debugging Connected in the notifications area when you plug it into your computer? Feb 25, 2016 at 5:58
  • Also, the thread you linked is for Android 4.0 ICS. I suspect it won't work for KitKat Feb 25, 2016 at 6:00
  • Probably the drivers also won't work. Feb 25, 2016 at 6:01
  • Confirmed. This won't work. It uses a root exploit limited to ICS only. Feb 25, 2016 at 6:04
  • Have you checked this out? Feb 25, 2016 at 6:08

1 Answer 1


Thanks to Tamoghna Chowdhury for the links to the XDA Developers thread. Apparently, my kernel date is too new and I can't unlock the bootloader on my phone. In order to root it, I would need to flash XT926 firmware on it as well. Closing question.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .