2

Yesterday, I set up a PIA VPN. I've configured it to use IPv4 over T-Mobile 4G LTE.

I'm unable to send or receive MMS while connected to the VPN -- they can be sent/received as normal when the VPN is disconnected. Any insight as to the origin or solution for this problem would be appreciated.

SMS works. Voice works. WiFi calling works.

  • Using L2TP/IPSec PSK.
  • VPN server is configured on the Android device using IP, rather than domain name.
  • DNS server is also configured by IP
  • I have no L2TP secret.
  • No IPSec ID
  • Using IPSec pre-shared key
  • Not using any DNS search domains
  • No forwarding routes configured

I suspect there is some sort of configuration issue with my APN settings; the current configuration works when disconnected from the VPN.

** Update - I haven't yet found a resolution to this specific issue. After getting frustrated using the manual configuration in the settings menu I decided I would try their official Android app. It will set up the connection for you. Unfortunately, the currently version of the app doesn't expose what specific configuration it is using.

APN Settings page 1 APN Settings page 2 APN Settings page 3 About this phone page

  • 1
    If you can send/receive MMS messages with the VPN disconnected, your APN settings are correct. Remember that MMS uses a data connection, not your normal "voice" connection like phone and SMS messages do. I can't say for certain, but this probably failing because you are not using T-Mobiles DNS servers or you are not accessing them from "inside" T-Mobiles network due to the VPN which will cause them to fail because the device is not seen as on Tmo's network. – acejavelin Feb 29 '16 at 17:36
  • @acejavelin Based on this, it sounds like configuring my connection to use TMO DNS is the correct option: this would seem to make sense if the MMSC can't be resolved. Will troubleshoot more later today and post updates... – Brian Melton-Grace - MSFT Feb 29 '16 at 18:21
  • It is just a guess, that is why I left it as a comment and not an answer, but it seems reasonable knowing that the APN is correct since it works when the VPN is disabled. – acejavelin Feb 29 '16 at 18:23
3

I've just found an issue in AOSP that tracks this and has a suggested fix for it:

I tried Textra as a texting replacement app (for other reasons). In the settings it has an option to use either System or Legacy protocols for MMS. It even tells the user to try System if they have a VPN enabled. I switched to System from the default Legacy, and now my MMS works flawlessly with a VPN running.

  • Thanks for sharing this @zamber -- I tried out Textra and it unfortunately didn't work for me. It appears to have worked for others in some instances, however. There seems to be a great many issues open against Android's Always-On VPN as evidenced by a site-specific search google.com/… – Brian Melton-Grace - MSFT Apr 6 '16 at 16:58
  • Doing site specific searches will do you no good as you'll get closed issues too. It looks like there are 25 open issues that match "always on vpn" code.google.com/p/android/issues/… . Take a look through these issues (and the old ones too) to see how you could debug your issue. – zamber Apr 7 '16 at 10:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.