3

I have just upgraded my phone (2nd Gen. Moto G) to 6 Marshmallow and now I can't install the Facebook app.

With Android 5 I had the app installed on the SD card (along with a bunch of other apps), but as part of the upgrade it insisted that I format the SD card so it could be used for apps. I'm assuming that the way 6.0 addresses the memory card is different to how 5.x did.

Once formatted I (obviously) lost all the apps that were installed there. I managed to reinstall them all - except Facebook. It doesn't say it's incompatible with my device, it apparently downloads OK but the installation phase just fails silently. I've tried it a number of times (after clearing caches, rebooting the phone, removing Facebook from the list of apps that have ever been installed) and get the same result. It will even crash the Play Store app and/or phone during the process.

I've examined the SD card on the phone and computer and I noticed that there were some folders dated from before today so I'm wondering whether the format was actually a format (or are the dates from the date the OS was created?) and there were still some folders that included "facebook" in their name.

Is there anything I can do to get the app to install - short of reinstalling the whole OS again - or am I just going to have to abandon this one for now?

  • Can you consider ejecting the external SD card and try installing the app again? – Firelord Feb 28 '16 at 1:10
  • 1
    @Firelord I tried that (indirectly), but I would have thought that a problem with the SD card would have affected all apps, not just Facebook. – ChrisF Feb 28 '16 at 1:35
0

Go to this link on your phone: Facebook APK And install the apk yourself but make sure you have unknown sources checked in the developer settings.

  • Any particular reason for linking apk4fun? – Firelord Feb 28 '16 at 1:09
  • @Firelord it is the most convenient site to download the apk without ads and waiting times – GHOSTX-FUZIONZ Feb 28 '16 at 1:20
0

I gave it a couple of weeks - enough time for Facebook to issue an update or two - and tried to install again and it apparently failed silently again so I decided to abandon it once and for all.

However, a couple of days later I noticed that Facebook was updating - so it had installed at the previous attempt.

I can't remember whether I'd cleared the cache or not, but I have had the problem with other apps where they think there's not enough space on the device to either download the update or install it and I've had to clear the cache to get it to work. However, in those cases I was told that the update had failed.

The solution was obviously to just keep trying and clear the cache just to be sure ;)

  • Still facing same issue. Not able to install Facebook app. Facebook app size is 40MB so keep trying means waste lots of data usage. – Hkachhia Mar 22 '16 at 6:29
  • @Hkachhia - try clearing your cache. It could be that the phone thinks there's insufficient space on your device. – ChrisF May 1 '16 at 20:35

protected by Community Apr 19 '16 at 13:36

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.