When I use widget for voice search and say 'weather' I get the results, but it is shown in Fahrenheit, even though,in settings it is chosen to show in Celsius.

Any solution?

  • Pull down from one of the Os in the Google logo in the Google now app – Suici Doga Feb 28 '16 at 9:16

This problem apparently is due to the device language selection.

If English (US) is chosen, Google defaults to temperature units used in US (Fahrenheit)

This is remedied by switching over to English (UK), where temperature units are in Celsius

Source: Accepted answer on Android wear,How do I change temperature units in Android wear weather app?


The other answer on this question didn't work for me. My phone was already on English (UK) and changing it to US and back did not help.

Instead what fixed it for me was:

  1. Open the Google app.
  2. Scroll down to the Weather card.
  3. Press the menu button on that card.
  4. Press "Change temperature units to °F".
  5. Press the menu again.
  6. Press "Change temperature units to °C".
  • Well they probably implemented that feature so user can use us language with Celsius units. – Једноруки Крстивоје Sep 17 '17 at 0:00
  • 1
    @Једноруки, I think this answer should now be accepted, because it is a solution rather than a workaround. – gdrt May 31 '18 at 18:42
  • @gdrt I disagree because first answer helped me and resolved an problem I had so... – Једноруки Крстивоје Jun 1 '18 at 23:05
  • @Једноруки, what if someone wants to keep using English (US) while being able to use Celsius units? The other answer solves the problem, while introducing another one. Yes, this question was asked by you, but it belongs to the whole community and it's also of your interest to update accepted answers as better ones come. – gdrt Jun 2 '18 at 10:36
  • @gdrt you see in my question that in settings it was set to Celsius but it ignored it due to phone language. Setting was there but didn't work probably because of bug. – Једноруки Крстивоје Jun 2 '18 at 15:39

If you use Android, just ask Google Assistant to change it from F to C permanently. It works for me. Google Assistant will say "I will remember your preference".


tap on you home home scree and go to select widgets.. under goolge select the at a glance widget and drag it to your desktop.. for me this changed the unit from F to C instantly...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.