0

I am working on an Xperia Ray ST18i otherwise known as urushi, unlocked, rooted, last running stock 4.0.4.
I was unable to install CWM with ROM manager app, which said it was incompatible with ST18i. I tried to install TWRP, same response. I tried to install CWM with x-Parts app, it said that it installed, but there was nothing there. Finally I found a tip to use the installer of older version of CWM, 5.027. I installed it, and it worked. The installer app recognized the device as an ST18i. I tested that I could reboot into recovery and operate it. Made nandroid backup.

Now attempting to install carbon rom 4.4.x.
Copied zip to sd card.
I extracted the boot.img, installed with fastboot, which responded with Flash operation complete.
Rebooted into recovery.
Wipe data. Wipe cache. Wipe dalvik. Install zip. Select zip file.
CWM starts installing.

Finding update package... Opening update package... Installing update...
However, aborts with error message: This package is for "ST18i,ST18a,urushi" devices; this is a "".
(Status 7) Installation Aborted.

Now it appears that the package is correct, the device is an ST18i. But it appears that CWM thinks the device is a "".

I tried the option "toggle script asserts" to disable, but it made no difference. (not sure if that is relevant)

Elsewhere on the web for someone who had a problem because the name in the package did not did not match name on device, I read some advice about decompressing the zip and editing the updater-script, and re-zipping it and pushing it to the sd card to flash.
However, what would I even put in there for the device type, "" ?

Or is it possible to comment out that check altogether?

Or is there a way to correctly specify to CWM what kind of device it is?

Or is there another solution?

(and as an aside, is there a better recovery for the Xperia Ray than CWM 5.027?)

Thank you for your assistance.

0

I found an answer here: http://forum.xda-developers.com/showpost.php?p=30908422&postcount=186

Edit the updater-script, but don't try to fix it - remove the condition altogether since I know I'm on the correct device.

Thanks adulfo!

PS. bizarrely, after powering down, when I returned to recovery, a different version (6.0.5.1) of recovery came up rather than 5.027. Possibly x-Parts had improperly installed CWM, and the second install 5.027 made it possible to access it, because after originally installing with x-Parts I could not boot into recovery. (Although that does not make sense either because x-Parts says it installs recovery into the system, and it is erased by flashing a ROM)

Still, I don't know why CWM did not recognize the device as an ST18i (and thereby failed the script), especially since it had done so during the installation of CWM recovery.

  • Oh, maybe I can shed some light on your last question. See, your device's code name, ST18i, is specified in a little file called "build.prop", which resides in the /system partition. My best guess is that one of the installers you used messed up such file, thereby altering the "ro.product.name" field. – Death Mask Salesman Feb 29 '16 at 18:33
  • Thank you for that light. I guess next time I try to install a ROM I'll have the same problem then? Is that file on the recovery partition? Is there a way to edit that to fix it? What would I put in that field, just ST18i? If I try to re-run the ROM Installer app now that I am on 4.4.4, would it install a 'good' version of CWM over the possibly corrupted one (and fix the device name) or would it still respond that there is no version of CWM for the ST18i? – Johnson Mar 1 '16 at 13:43
  • The "build.prop" is saved on the /system partition. And yes, you can fix it manually by editing it. Either use a fext editor, or a Build Prop Editor from the Google Play Store. The benefit of using the latter is that you'll be able to make a handy backup of the file, so you can avoid the hassle of editing it once more. As for editing it... you want to edit the "ro.product.name" field, in order to provide your device's code name. Either write "ST18i", or "urushi". By doing that, you'll make sure that any ROM you wish to install will be able to check the device's model, if needed. – Death Mask Salesman Mar 1 '16 at 13:57
  • According the Build Prop Editor app, ro.product.name was already set to ST18i. ro.product.model was also already set to ST18i. ro.product.manufacturer was Sony Ericsson. – Johnson Mar 1 '16 at 21:44
  • That should be as such because you flashed the ROM in which updater-script you removed the condition block. It recteated the build.prop for you. – Death Mask Salesman Mar 2 '16 at 6:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.