1

My sister came up with her phone asking for password to decrypt storage and she said she didn't set any password. I can't put the phone on USB Debugging cause i don't have access to phone settings.

I tried to use Sony PC Companion to reinstall Android but it says that was not found any software to the phone. Also tried to install Android using a using a build by FlashTools but i'm getting an error to write files based on write permissions on phone since it's locked as encrypted.

The Recovery Mode (using power button and volume-up) doesn't work either.

How can i reset to factory settings or even reinstall Android with these conditions?

8
  • I'm pretty sure booting into recovery and wiping /data will be your only option then. Unless, however, you somehow get the password. – GiantTree Feb 28 '16 at 19:21
  • That's the problem. I can't boot into recovery mode. It does'n work when using power button and volume-up or even volume-down. I tried so many ways and always boot to the system instead of recovery mode screen. – Henrique Schreiner Feb 28 '16 at 19:24
  • Can you try the link given below. Hardreset Sony Xperia-M – Abhijeet Padole Feb 28 '16 at 20:39
  • Already tried all of these methods. – Henrique Schreiner Feb 28 '16 at 22:54
  • Actually, the phone runs Android Jelly Bean 4.3, but i can install Android Lollipop too. – Henrique Schreiner Feb 28 '16 at 22:56

Browse other questions tagged or ask your own question.