1

I've tried reformatting as portable storage and internal storage and neither work, choosing portable storage shows no errors it just doesn't do anything while internal storage errors.

I've tried taking out the card and plugging it into my computer to reformat but Windows doesn't pick it up at all (including the SDFormatter tool) and GParted gives the following error when trying to change anything:

Input/output error during write on /dev/mmcblk0

Error fsyncing/closing /dev/mmcblk0: Input/output error

Trying to reformat it using the Disks tool in Mint gives me this error:

Error synchronizing after initial wipe: Timed out waiting for object(udisks-error-quark,0)

The parted command line tool gives similar errors.

I've been tearing my hair out all day over this, I can't seem to find any way to bring the SD card back. This is actually the second card this has happened to, I ended up throwing away the first one and then I've gone and done it again.

I've had a look at http://nelenkov.blogspot.co.uk/2015/06/decrypting-android-m-adopted-storage.html, but as I've flashed a new ROM the key is gone?

Any help is appreciated!

  • If the card is good, even if encrypted, you should be able use Gparted to delete the partition table and write a new one and be good to go. If not, sounds like the card is bad. – acejavelin Feb 28 '16 at 23:10
  • Yeah that's what I assumed the first time, but for this to happen to two cards one after the other just doesn't make any sense. The current card is brand new off Amazon. – Joe Bushell Feb 28 '16 at 23:11
  • Odd, I have a Moto G 2015 with a 64GB card, I have moved it back and forth from portable to adopted storage multiple times, and even when encrypted put it my Linux box, it always sees the card properly, but not the data. What device? – acejavelin Feb 28 '16 at 23:14
  • There's nothing Android can do on a software level to an SD card to make it unusable anywhere else. Either the card was bad, or your phone's hardware fried it. What is the brand/model of the card? What phone do you have? Have different types of SD card worked in it before? – Matthew Read Feb 28 '16 at 23:16
  • Oddly enough, a Moto G 2015 with a 64GB card. So it could be possible that I just have a killer phone? SD Cards have always worked in it fine, I was using the first card for ages as regular external memory in Android 5.x. I jumped straight into the internal storage stuff when I upgraded to Marshmallow a few weeks ago. Not sure on the first card, this new one is a Samsung EVO+ 64GB – Joe Bushell Feb 28 '16 at 23:18
0

Use DISKPART utility to create new partitions and reformatting them. I suggest using the below procedure by inserting the card into an adapter and then into the PC.

This is the part which has no Android, but is done on Windows PC. Here we go.

  1. First open a command prompt window with administrative rights.
  2. An Administrator command prompt will open. Type in diskpart.
  3. Then enter this command "list disk" without the quotes to display all active disks on your machine.
  4. Now choose the disk which is your SDCARD using Select command "Select disk 1".
  5. Type "clean" with no quotes. Hit enter.
  6. Type in "create partition primary", partition will be created.
  7. Type "Active", this will mark the partition as active.
  8. Now, the formatting of partition in format you like, usually SDCARD is FAT32. Type "format fs=fat32 label="NAME THE CARD" quick".
  9. Then type "assign" and then "exit".

Now you have a formatted SD CARD!

  • I just tried using diskpart and running the clean command but I just get diskpart has encountered an error the request could not be performed because of an i/o error. Worried I may actually have a killer phone. – Joe Bushell Feb 29 '16 at 23:23
  • @JoeBushell are you using a sdcard adapter to connect to PC? Caution: Don't try to use diskpart while the card is inside your Phone. – Rahul Bali Mar 1 '16 at 18:47
  • I'm using the SD Card reader in my laptop, gonna to test it with a different laptop next week – Joe Bushell Mar 5 '16 at 21:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.