1

I've got a problem when trying to set up my (two) nexus'es 5. (issue reproducible on both my phones, which kinda excludes hardware issues)

1: I download factory images from google's page (tried all 6.0.1 builds for hammerhead), unpack them, enter bootloader, and flash-all.sh

2: I set up the phone, log in to google, set up USB debugging, and adb reboot bootloader

3: I flash TWRP by fastboot flash recovery twrp-..-hammerhead.img (tried 3.0.0.0 and 2.8.7.0 version)

After that, accessing recovery is night impossible. Sometimes I can enter Recovery mode straight from bootloader. TWRP will launch, but only once. Exiting it, booting up system, and then adb reboot recovery / adb reboot bootloader and from it selecting Recovery will only show google logo with the open padlock icon for a few moments, then the screen will blank, phone will vibrate, the logo+padlock will show again, and from it it will boot system.

Entering recovery will invariably end with it booting system. In this state, flashing recovery from bootloader again will do nothing, only re-flashing factory image will help (but not for long)

Has something changed in 6.0.1? Are there any steps I'm missing when flashing recovery? Am I doing something wrong?

  • My situation with Nexus 6 and Android M images is even worse. Regardless of whether TWRP is flashed from bootloader or not, if I attempt to boot into recovery mode, it goes straight into "Erasing". The only thing I was successfully able to do was boot into TWRP directly from fastboot mode using fastboot boot IMG_PATH. Afterwards, TWRP should give you an option to modify system partition so it can persist after a reboot. If you don't modify system partition, you would end up at the beginning of this same cycle. Try it and let us know the result. – Firelord Mar 1 '16 at 5:43
0

The same thing happened to my Nexus 5 as well,when I upgraded to android M and tried rooting and flashing recovery.The process went perfectly fine but when I tried to enter recovery mode it didn't happen. For which I tried using the Nexus Root Toolkit,which has several functionalities required.I tried rooting my phone and then flashing the stock recovery,everything worked like a charm for me. So I would suggest you to download the Nexus Root Toolkit by wug fresh then first try to flash the stock ROM again there after Root followed by flashing the custom recovery.

  • It seems that wug's toolkit is windows only. I do not have windows installed, thus this option is out, unluckily :( – user905747 Mar 1 '16 at 6:54
  • At the moment the development has been going on but the developer isn't confident about the ETA,as quoted by him that the software needs to be re-written for supporting Mac.Meanwhile you can try using it via VM. – Phoenix Mar 2 '16 at 4:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.