I have recently installed Android 6 on my Nexus.

I also have AFWall+ for [un]blocking selected application from accessing internet.

However, every time I connect to a wifi an exclamation mark will appear and Android will soon disconnect from it. Also a popup message asks me to disconnect because it cannot connect to internet.

However I can access internet indeed via wifi.

What process should I add to whitelist in order for Android not to disconnectme after a few minutes?

  • AFWall+ has nothing to do with that. It is a feature of Android. Related: Force MarshMallow to keep a Wi-Fi without Internet access – Firelord Mar 1 '16 at 15:50
  • @Firelord considering AFWall+ requires root, are you sure one could not "accidentally" blacklist the corresponding process as well? // OP: Does that also happen when you disable AFWall+? – Izzy Mar 1 '16 at 16:36
  • If I disable the firewall entirely no exclamation mark on wifi icon. Also I didn't understand. Are you telling me that wifi connection checker by Android OS is running as root? Makes little sense but I don't like to give root internet permission unless really necessary – usr-local-ΕΨΗΕΛΩΝ Mar 1 '16 at 16:57

I had the same problem. To find which app you need to allow you can turn on firewall logs in AFWall+. The log gives a log when traffic is blocked and shows which app was blocked.

  • Enable AFWall+ (if you had it disabled temporarily)
  • Settings->Preferences->Log->Enable logs
  • Menu->Firewall logs->Menu->Clear log
  • Disable and then enable WiFi to trigger the log
  • Menu->Firewall logs

The apps involved might vary from one device to another so you should check your own log rather than assuming it's the same as mine. I saw log entries for "root" and "com.quicince.cne.CNEService" (Qualcomm specific, and counts as part of "Android system" in AFWall+).

I have solved the problem by allowing traffic over WiFi for both the above entries. In fact I think I probably mostly don't need root, but without root the solution was not quite as reliable to remove the error.

  • Perfect, thank you. For my phone (running CM13) I needed to allow Data Usage Provider – Wumms Oct 11 '16 at 15:18

As the other answer and its comment show, the culprit is Data Usage Provider, which tries to connect to Google servers to test connectivity.

You could of course whitelist it in AFWall+, but if you'd rather not have your phone announce your IP to the mothership you need to disable "captive portal detection": as root, run in a terminal (or in adb shell)

settings put global captive_portal_detection_enabled 0

Your Answer

 
discard

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.