I recently got the Marshmallow update on my MotoG 2nd gen (2014). I was hoping that my battery will last longer if I enable battery optimisation. But I cant seem to enable it. I can go to the battery settings and open battery optimisation. It shows Not Optimised. If I select All Apps, it shows optimising battery use for apps listed. When I go back to battery screen and then again to optimisation it still shows Not Optimised. It keeps resetting to Not Optimised. How can I make the optimisation work ?

pic1 pic2 pic3

The screenshots repeat if I go back from 3 to 1.

  • "How can I make the optimization work know" just let the phone enter in deep sleep. – xangua Mar 2 '16 at 7:30

You don't need to do anything. Not optimised just shows the apps that are considered system critical and are excluded from battery optimisation. If you select the All apps option, that just lists all the apps that are battery optimised.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.