The following problem is occurring today, even though I had no problems doing the exact same thing yesterday: I have connected the phone to my USB port on my computer. The phone is charging, so there is an electric connection, however the notification saying "USB connection methods" isn't there. The computer gives no sign or reaction either. What to do now?

  • I have switched cables.
  • I took the SD card out today and I have put it back in.
  • I tried all my USB ports already.
  • The cable I used yesterday isn't working either.
  • What does getprop persist.sys.usb.config say? Likely MTP won't be in there. If you're rooted you can setprop persist.sys.usb.config mtp,ptp,adb to restore mtp and ptp. – Aaron Gillion Mar 2 '16 at 20:01

I have managed to solve my problem. It seems that, due to some reason, my USB port's power limit was exceeded and it froze itself. I'm not fully sure what caused this to occur, but after disconnecting everything and resetting my USB ports it somehow worked again..

The following message occured after trying a few USB ports: popup message

I disconnected my phone and pressed reset after clicking the popup and it seemed to do the trick. A more thorough explanation on what to do in case of this popup can be found here.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.