2

and the pc doesn't even recognise it (i've tried the volume and power buttoms but sure it didn't work because the phone didn't turn on) when i connect it to pc using kies it gives me a black screen on my phone with the drawing of my phone and pc with "!" between them but as i mentioned b4 the pc doesn't feel a thing plzz help me

  • Just happened to me too and the solution (hold volume down and home then insert battery) totally worked!!! Thank you! Thought I lost everything – user8606 Oct 8 '11 at 10:50
3

I'd try removing the battery and plugging it into USB. Then, while holding both Volume Down and Home, insert the battery and wait. This should get you into Download Mode (screen with yellow triangle) and Kies should be able to update you.

If this doesn't work try other key combos -- both volume buttons, or VolUp+Home. If they don't work either, disconnect from USB and put the battery in. Then while holding one of the key combos, click the Power button and wait. Yank the battery and reinsert to try a different combo if need be.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.