2

I need to flash a new firmware for my china X-302 Tablet (detail below). From the producer i have got a package containing firmware, stock rom, sp flash tool, drivers etc. When I want to use flash_tool.exe select and add download agent (for example MTK_AllInOne_DA.bin or more) then pops up an error:

ERROR BROM: S_FTHND_FILE_LOAD_FAIL (5008)

[HINT]:

Tablet at that moment I connected. Usb driver da Vcom I have installed.


tablet: x-302 of Dragon - h701

Android 4.4.2 kernel 3 April 67

Build ALPS.KK1.MP1.V2.11

Tested on Windows 7 32bit, Windows 10 64bit (I also tried compactibility mode).

UPDATE

Standard drivers are installed. The tablet normally communicate, install apk using adb, run and Debug android/Xamarin applications using Visual Studio. This is all OK. If you think MediaTek USB VCOM drivers, so you've got installed:

MediaTek DA USB VCOM (Android) (COM18)

MediaTek Preloader USB VCOM (Android) (COM19)

MediaTek USB Port (Android) (COM22)

MTK USB Debug Port (COM20)

MTK USB Modem Port (COM21)

I had to allow installation of unsigned drivers, and then writes were installed OK. But device has warning "This device can not start. (Code 10). I tried different ways to install or other version, but always writes this warning. However, on the forum, I found it's not a problem. SP Flash tool may work...

1
  • Assuming your computer runs Windows: have you checked with the device manager (Start › Control Panel › Device Manager) whether your tablet was recognized and integrated correctly?
    – Izzy
    Mar 3, 2016 at 11:08

1 Answer 1

1

I finally discovered that the problem was in the path to download agent, where was the Chinese characters for example :

**x-302 NEW firmware \ 线 刷 工具 和 驱动 \ mt65xx preloader 驱动 **

I just retype to :

**x-302 NEW firmware\Flash\mt65xx preloader**

and then it works correctly and retrieve the download agent. In all the tutorials I could see that the used path with Chinese characteristics and it worked. However, in my case not.

Here is some helpfully link : Tutorial flash device with mediatek chip 1

Tutorial flash device with mediatek chip 2

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .