1

I am using Micromax unite 2 phone. Its an MT6582 phone running on KK . Recently i flashed a new rom ( exception OS) and after booting up , i found that i cannot access the internal sd card. The stock file manager doesnt even show that there is an internal sd card. I also tried ES file explorer but to no avail. Also when i connect to my pc via usb , after selecting usb storage, only the external sd card shows up. Lastly , i tried accesing the internal sd card via recovery( PhilZ touch 6) and strangely it works. Also when i mount the usb storage via the recovery , my pc shows the internal as well as external sd card and im able to access both of them from pc. I have tried flashing the same rom again and again and also some other roms but the problem persists. Any help would be very much appreciated.... thank you..

  • Which particular build of that custom ROM are you using? Is it a nightly or a stable one? If nightly, please switch to a stable one and report us your findings. As for the other ROM's please list their name, version of particular build tried and stability status of them. // Can you try a different kernel and see what happens? Perhaps using the stock ROM's kernel on your custom ROM (be ready for any boot issue) and see if the issue persist. – Firelord Mar 5 '16 at 7:56
  • 1
    Thanks for the quick reply. Yes the dev of the rom menioned that it is a stable one..... and the second rom that i tried ( and which is currently running on my phone) is Remix UI and its a stable one too. And if i try a different kernel and something happens , will i be able to go back using the nandroid backup that i created? – Abhigyan Mukherjee Mar 6 '16 at 6:39
  • Also i noted that the file explorer( stock and ES) were labeling external SD card as "sdcard0" while the Recovery was showing it as "sdcard1" and the internal SD card as "sdcard0". – Abhigyan Mukherjee Mar 6 '16 at 6:49
  • You must be having external SD card as default storage, so it is fine if Android shows it as sdcard0. Anyhow, as for any boot issue, yes, nandroid backup should be able to correct it, provided that you keep it safe from data wipe and doesn't mess with recovery. – Firelord Mar 6 '16 at 10:57
1

OK guys I think I found a Solution. This is what i did :- I flashed another ROM today ( Resurrection Remix, CM 12 based) and flashed a 6.08 GB Repartition zip and booted the phone. The first attempt was unsuccesful and the problem persisted , so i booted into recovery, then wiped all , and flashed the ROM again, this time, without flashing the repartition. And when i booted up , i found that it had been fixed. Settings showed a total of 6.08 GB Internal Storage. if any of you have similar issues , you could try this.

  • Cannot Understand Your Answer. Mine Cynogenmod 12.1 also shows sd card as SDcard1 and internal as sdcard0 and so when I tried to flash Blisspop rom on it the internal storage not showing up. wanted to use your technique but cannot understand your answer. – Aman Dec 28 '16 at 10:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.