I got various problems.

Sometimes I get parse error. Sometimes it just stuck at 0%

I did everything


My SuperSU is updated.

This is my ONLY backup.

I used to do xiaomi back up using settings. However,

I have no way to move the back up to the PC because I don't know where xiaomi stored the back up. When I flash the new ROM it seems that the back up is gone too. Xiaomi pc suite cannot back up ADB back up fail.

The only back up I have is that titanium back up.

Now I tried to restore and I got the back up stuck at 0%. I tried everything.

I tried upgrading to pro.

I change app processing mode from auto direct to auto indirect. The parse error is gone but still stuck at 0%.

I reselect /TitaniumBackup as backup directory.

No avail.

What sort of back up titanium back up make anyway? Do they just store the apk? Are titanium back up apps the only way to restore titanium back up backups?

  • I'm confused - have you made a backup with TitaniumBackup and can't restore it? It would help to know which phone make and model you have, and which Android OS version it's running. Also please get some screenshots of the errors. – Chahk Mar 7 '16 at 13:45
  • xiaomi. It's working now. – user4951 Mar 7 '16 at 14:00
  • If your problem is solved, please answer with how you solved it (and accept that answer) or consider removing the question. – Paul Ratazzi Mar 8 '16 at 15:44
  • I added an answer but the answer is deleted due to using too many paragraph. I have fixed that but can't undelete it. – user4951 Mar 9 '16 at 2:19

Some websites noted that the user should update su binary. The thing is, I thought my su is up to date. There is no easy way to update su binary. I couldn't uninstall supersu. If I press and hold there is no option to delete because supersu is a system app. When I opened Play Store it read "open". No uninstall option either. So I upgraded my SuperSU to pro version. Still, Titanium Backup failed.

I later browsed into settings of SuperSU. There was an option to clean up super su for reinstall. I selected that option, rebooted the phone and noticed that SuperSU was gone. I later reinstalled SuperSU, launched it and sure enough, SuperSU complained about binary in need of an update. I updated su normally and ran titanium backup again. This time it worked.

I am not sure if this step is also necessary but Titanium Backup warned me about some name space option in SuperSU. I changed that setting. (nope i do not think it's necessary but I would mention it just in case).

Note: I did it again the second time. My xiaomi then have many bugs. It seems that after some flash we should only restore user apps and not system apps.

Then I used xiaomi own backup mechanism, upload the back up to my computer, reflash, and then restore from xiaomi own backup mechanism and it works. Things are working fine now. I can fully enscrypt my phone, which is impossible on MIUI 7.0. I have root. And Everything is working flawlessly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.