0

When attempting to connect to my school's wifi, I enter my username and password and connect to the network. Below the wifi name it says Connected, no Internet and the wifi icon at the top right of the status bar is there, but with an exclamation mark! I can ping the router, but not google. My Android device is a Samsung Galaxy S2 i9100 and I'm running CM13 (Marshmallow). I've tried rebooting, forgetting network, wiping cache, resetting network settings and also factory resetting. Any help appreciated, thanks!

  • 1
    What's your question? This is a problem with the Wi-Fi network, not your phone. – Dan Hulme Mar 11 '16 at 12:55
  • Hmm, other devices can connect with ease, my iPod for example. – Jenny Mar 11 '16 at 13:24
  • Have you tried with changing IP Settings to Static followed by setting a static and correct IP address (shouldn't be in use), subnet and 8.8.8.8 as DNS? You may also have to tap the Wi-Fi's entry and choose Connect. – Firelord Mar 12 '16 at 8:40
0

This is the exact problem I met. Since you cannot ping google I'd guess you're from China, just like me. My i9300 had the exact problem as yours. After downgrading to CM11 everything is fine.

Then I bought a Nexus 6P. Guess what? It has the same problem. After confirming with a friend who works in Huawei, this is actually a Marshmallow feature, or bug in our case. When you cannot connect to google service, Marshmallow would think that there is no internet connection.

Update: Found a possible fix which worked for me:

  1. Create a new user via Settings -> Users
  2. While it is trying to connect the network (which will take some time, or forever in our case), power off the phone.
  3. Turn on the phone again. The "no internet" warning should be gone.
  4. You may need to delete the newly created account.**
  • See here for a descent solution. Here is a Chinese version. – Yai0Phah Jun 21 '16 at 14:31
  • @FrankScience Guess you mean decent. My solution is crude I have to admit. Thanks for the link. – Wang Dingwei Jun 22 '16 at 1:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.